v2016 - Wasted space in Entity Info panel - make vertically sizable

2016

#1

The new entity info tray seems to have quite some wasted empty space. Both with show and hide details. On win7X64. See red box in image.
Edit: the other trays can be scaled, this one can’t.


#2

It’s there for hidden fields that only show up for certain selections:


#3

They are panels, not trays.

You can create a floating tray just for that one panel if you wish, then size the whole tray.

Example:


#4

Thanks for the replies. Still testing it.

You can’t auto-fold the panels can we? This new tray/panel, even if all the individual elements are closed, still takes a lot of screenspace (see pic).
In v15 it was just double clicking the elements (layers/outliner etc) and you had them opened/closed. In v16 it seems you have to scale the panel to temporary get some extra workspace.

Have to test more…


#5

Dock the tray you wish to hide, then “unpin” it, and it will slide out of the way and become a tab on the margin. Then just hover the mouse pointer over the margin tab and it slides back into view.


#6

One of big upsides of the new trays make it so that you don’t need to collapse dialogs. Instead you can scroll if your desired dialog isn’t on the screen.

And as Dan points out, unpinning will maximize your modeling window size.

Cheers!
~Bryce


#7

I definitely like the tray thing. It basically mimics the screen layout I’ve used for years with the drawing window a little narrower than the screen so I could leave the utility windows just to the right of the drawing space. that way those windows never covered my drawing space at all. The upside besides scrolling them now is that I gain additional space for toolbars up at the top. Some empty space in the tray isn’t any problem for me.

Thanks for adding it.


#8

Had some more time to play. The margin tabs combined with a keypress to open them seem to work nice for me. Maximum workspace + a quick way to open the desired info (Outliner hierarchy, layers, etc).
An improvement to me would be if it were a real toggle. At the moment it is a temporary visibility change. After a split second it auto closes.


#9

It is giving you time to move the mouse cursor over it, which will then keep it visible so you can use it.


#10

I know and its nice. Its named a ‘toggle’ though in the keyboard shortcuts, I wonder why it isn’t a real toggle or at least there’s an option to change the duration of the auto close timer.


#11

Some more tray-getting-used-to:

On my laptop, without using a mouse:
I create an object, group it, right-click and choose ‘Soften-Smooth Edges’ - immediately the sidepanel opens AND my mouse pointer is moved onto the degree slider in the Soften Edges dialog. This automatic moving of the mouse is confusing and counter-intuitive to me.

On my desktop, using a Wacom pad:
I create an object, group it, right-click and choose ‘Soften-Smooth Edges’ - the sidepanel opens and luckily the mouse is still on the object.

My personal preference would be that tools don’t move the mouse pointer - only the user does. Is this working as intended?


#12

I believe it is intended, but perhaps not working entirely as intended.

The mouse must be re-positioned when the tray is hidden, so as to unhide the tray and redirect UI focus to the Soften Edges panel in that tray.

So, I guess as it is now implemented, if that panel is not on a hidden tray, then you have complete control over the mouse (and you need to go looking for the tray if you wish to make a change.)

There could be a need for a new feature for an option somewhere in the Preferences dialog, to “Never re-position cursor during Soften Edges” ?


#13

Dan, as always, thanks for your reply.

My intuition says that no software should ever take control of the mouse. I really can’t think of any examples where I’ve seen that kind of behavior before. Its confusing and messes up your mouse - mousemat - relative screen position.

In the picture, there’s no need to move the mouse from point 1 where the soften/smooth edges command is started. Still, the mouse gets moved to point 2. I guess it’s implemented to prevent the tray from auto-closing. At the moment, the auto-close timer is set on a very low value.

For new features/options in the Preferences, I would prefer:

  • Tray behavior is toggle (and no autoclose) -> press key = open/close if tray is closed/open.
  • Tray autoclose Timer value = X seconds (some people want it fast, others more slow).
  • never re-position mouse.


#14

I agree that it should slide away slower, but how about only closing when another tool is selected?
So the fill would remain rolled out while you were filling, the components while you were working with them… etc.


#15

There are various “Intellimouse” and Logitech settings that allow mouse focus to jump to what your OS determines to be the most likely place you will want it to be.

I’m not saying it’s the case here as mine goes to the slider too with all the smart move options unticked, just pointing out that it’s not an uncommon action.


#16

I am totally in favor with adding options that let the user run SketchUp the way they wish to.