Trays are annoying. Can I get Entity Info the old way


#1

I used to be able to call up whatever dialog windows I wanted e.g. Entity Info, Materials, Components in whatever combination I wanted. I could eliminate any one I wanted. I could minimize them. I could move the order of them. Now I have a “tray” that I can’t minimize. I can only close it. And then reopen when I need it again. And it is always the same size unless I manually drag the corners. If I add or remove a dialog the tray is still the same size, and often in the way of my drawing.

Is there a solution to this? Am I missing something? Can I go back to the old way of handling these dialogs?


#2

Drag the Entity Info dialog off the tray to make it a separate, floating tray you can resize. That’s the best that can be done (at least for now.)


#3

I left clicked on the Entity Info dialog and then tried to drag but it wouldn’t move off the tray. Is there some trick I’m missing?

I’m just getting acquainted with the Trays for the first time. They seem weird. If I make a new tray it seems that whatever dialogs I activate for that tray are taken off the other tray. So what’s the point? I can have a tray with just the Entity Info dialog on it, but it can’t minimize/maximize with a click. So now it just takes up more space. Any idea what is the benefit of trays? I assume there must have been some benefit in mind.


#4

Being able to have the same dialog in more than one tray is a feature request.

To make a tray float, first the tray needs to be made. Unpin the tray if pinned - the tray remains fully open and doesn’t collapse to the sidebar. Now drag the tray from the tray title bar into the workspace using the left mouse button. Resize tray as needed.


#5

Thank you.
The problem with this solution is that in order to get the tray out of your way you have to close it and when you want it back, go to Window>Tray>Show Tray. Previously I could just click on the dialog title and it minimized. When I want I back I click on the title and it is back. I liked the old way better. But this won’t kill me. I don’t see any advantage to the trays at all. I could do everything before and more simply and more flexibly. I could have any number of dialogs. They could all be grouped together or they could be separate. They could be the same size of different. I could minimize one or more at any time and it cleared space on the screen. Minimizing one or more dialogs in the tray don’t change the tray size so it is still in the way (e.g. if you wanted to minimize several dialogs to make more space on the screen, but get them back quickly whenever you wanted.


#6

If you have pinned trays, r-click the sidebar for option to open trays. Also you can set up a keyboard shortcuts in preferences. In Window > Preferences > Shortcuts, search using the tray title for your options.


#7

Please forgive my ignorance. How do you pin a tray?
Trying to do that I noticed that I can right click on the tray and then other trays are shown and I can open or close them.


Tray stuck in menu bar
#8

Try the push pin at the top. It hides the tray in a sidebar at the left or right. The official name is Auto Hide.


#9

… or you can just hover over hidden (unpinned) tray tabs in the sidebar, and they will slide out into view.


#10

I have to agree with you there. The new trays are a PITA


#11

or just switch over to mac! The mac version doesn’t have the new trays.


#12

Here’s an example of the problem. All the dialogs are minimized but the tray blocks a big part of the screen.


#13

Why don’t you enable Auto Hide?

Anssi


#14

You made just one floating tray and did not resize it. Above I showed the size of the floater I use as well as all the auto hidden trays listed in the right sidebar. The visibility of floating and pinned trays can easily be toggled on and off with a keyboard shortcut.

I don’t experience any “problems” - just more control. If all else fails, RTFM.


#15

How do you do that?

I didn’t know there was an autohide for the Tray. When does it activate? i.e. how does it know when to hide?


#16

Scroll up to the 6th post for auto hide picture, and go to the page linked in my last post.


#17

See: SketchUp Help: Customizing Your Workspace > Arranging dialog boxes and trays


Also FYI, there is also another major discussion thread on the new tray system:


#18

I found this sentence in the Help section, "if you would like to have a clean drawing space with no dialog boxes, select the pin icon in the top right corner of the tray. This puts the tray in Auto Hide mode."
However, I do not see any pin icon.
Screen shot of my tray


#19

You don’t, because your tray is undocked. You need to dock it to the right, left, top or bottom of your SketchUp window. Grab the tray by its header and SketchUp will display an icon with a four-way arrow/cross in the middle of your screen. Drag the tray to the arrow that corresponds to the edge you want and release. It should move to place, and, now, the pin icon should appear.

Anssi


#20

Or go to Window > New tray or Window Manage Trays and make a new tray. The new tray will be pinned (have the arrow.)

It’s unnecessary to do everything in one tray. My animation above have all three tray states: floating, pinned and auto hide.