V17 Follow Me defect


#1

I have part of a castle wall containing arrow loops, and wish to run a 1" x 1" chamfer around each profile. You will note that SketchUp fails to trim the supporting face consistently…

If the geometry is first moved to the origin, then the correct result is produced! (and the excess/unwanted chamfer side faces can then be deleted)

It therefore appears that SketchUp has an inherent deficiency processing tolerances for geometry far from the origin.

I would apologise for modelling my large local castle! - but it is no bigger than a small shopping centre and is thus not of unreasonable dimensions (I hope!).
(The original model origin/axes is central within the model)

I attach a copy of the geometry so that this serious issue can be reproduced and addressed, promptly (I hope!)…
V17 Follow Me defect.skp (22.6 KB)


#2

Why not just make a component that cuts the opening and glues to “any”

See if this helps.

Shep

V17 Follow Me defect perhaps not.skp (47.4 KB)


#3

I’m not sure why the face being there affects the follow me results, but simply deleting the main wall face so that the line to be followed is isolated solves the problem. It’s easy to redraw one line to get the wall face back afterwards.

Also, I get identical results at the location you have it, or at the origin. Whatever you have going wrong isn’t affected by the distance from the origin.


#4

Like Colin, I also got the same results no matter where it was located relative to the origin.

The other thing I noticed is the triangle you are using for the profile is not aligned correctly. That would be cause for the problem.

Frankly, I would probably use a different method for creating the bevels. I’d either use Offset and Auto-Fold or I’d use the Round Corner extension. Both options would make very quick work of it.