Upload Extension Failed

Dear Friends, When I try to submit my extension I receive following message.
Something went wrong while submitting your extension. Please try again.
Is it my problem or EW problem? Thank you for your help in advance.

After several hours still same problem.

I can see that someone submitted a test extension today, so maybe it is working now?

If it isn’t working it may not get fixed until Monday.

Same problem today. Thank you for your attention.

I successfully submitted some of our own extensions today. Have you tried to signing out and in again?

I signing out and in same problem. Also I deleted draft and created new one, Same problem. Thank you for your attention.

What is the structure of your .rbz?
How large is it?
I have had problems in the past uploading .rbz’s larger than 50mb.

Hello folks,

Just to give some heads-up about it, it really seems an issue with the Extension’s Warehouse. I also got the same issue on Error code 500 while sending a new extension to the warehouse - #4 by DanRathbun .

It seems like by some (obviously unknown) reason, CloudFront is currently denying the extension upload. As CloudFront is used for CDN purposes, maybe its something related to some key that was rotated. Anyway, we need SketchUp team to check it, folks.


1 Like

rbz file size is less than 10K.

I check and change everything but always same problem happen. I hope Sketchup team can solve this problem.

There may be an issue with how the RBZ is formatted. Could you share it here, alternatively share some screenshots of the file structure if you don’t want to share the code itself?

MAJ_Door.rbz (5.5 KB)
Thank you for your attention.

The root file and folder should have the same name.


It appears Extension Warehouse as of now doesn’t show specific error messages regarding to RBZ formatting. Does it work if you make the registrar file an support folder name match?

I planed to have one folder and different extension on it but seems it is not possible. When I consider same root file and folder my problem solved. Thank you.

1 Like

Glad it helped.
It is a prerequisite to have the root .rb file and the folder sharing the same name.