Unwanted blue lines


#1

Hi guys and girls,

Sorry I am sure this is very much a stupid question but I am only new so bear with me.

I am looking to join two parts together but it says one of them is not a solid, I believe it is because of the dotted blue lines on one of the faces. This is what I am talking about:

As seen in the following link, the two objects are what I am trying to join together for either 3D printing or turning in a CNC mill. The cone shaped part is one object and the rounded semi-circle is another: http://imgur.com/OCWXxTQ

If anyone needs the sketchup file, I can get that to you as well. The project is very nearly completed, I just need to get it all joined together as one piece!

Any help will be very much appreciated by this clueless newbie!

Kind Regards,

Owen.


#2

Attach the model here so it can be looked at.


#3

Hi,

Here is the Sketchup file.

https://drive.google.com/file/d/0B-AomWpkYkgReGJWNktXMS1XOFk/view?usp=sharing

Thank you!


#4

You don’t need to use google drive if the file is less than 3mb, you can attach it here.

I removed 2 hidden lines that were causing the non solid issue. You can see them in your screenshot above, the two lines hanging off the rim. Turn on hidden geometry so you can see them without them needing to be selected.
Both groups are now individual solids.

Petticoat solid.skp (225.9 KB)


#5

Sorry, I must be getting something wrong. I still see some of the blue lines when I open the file. I removed these using hidden geometry (Thanks! Never noticed that one before!) and used the pencil tool to replace the face that was removed when I removed the lines.

But now I am stuck on how to create one object out of the two. I was hoping to use the Outer Shell tool but looking at it further, I’ve realised that probably won’t work. Sketchup help suggests the join tool but I can’t find that in my toolbar. Both objects are ready to join together, I just can’t work out how!


#6

The blue lines are the hidden geometry highlighted when they are selected. If a face is curved it will always have these lines. They just aren’t visible when you haven’t selected them.

Your two pieces are a little troublesome because the curves are shallow for the scale. Plus you have made a shape that fits over the other shape rather than slices through it.
Here it is fixed, It was easier to fix it than to type how to do it.
If you want I can give an explanation latter, too busy just now.
Petticoat Full solid.skp (376.5 KB)


#7

Cheers mate! Very much appreciated. When you get the time, I would be interested in hearing the how and why it works. Why were the lines only on one side of the object? I would have thought if it was curved, it would be symmetrical on both sides of the object?


#8

The lines are part of the faces not the object, so you will see them on both sides of the face. They are what makes the faces possible.
Here you can see when I triple click an apparently smooth curve you get the blue dividing lines, plus a hidden stray one sticking out the top. You see them on the back of the face the same. I turn on hidden geometry so I can see them and select and delete the stray.


#9

There are no curves in SketchUp.
All geometry is constructed of straight Edges and flat Faces.
Thus, a circle, arc or curve in SketchUp is comprised of many straight segments or sides.
Click … View > Hidden Geometry to see all the edges in your model.