Unioning two solids results in one disappearing (kind of)

solid
union

#1

I am modelling a water bottle top and I have two solid components that I want to Union together. I’ve successfully Unioned elsewhere in the model, but the result of Unioning two overlapping solids is bizarre and acts as though something’s being deleted instead.

Picture of the “after” (picture of the “before” is in the .zip attachment, I’m limited by this forum to only posting one image… :frowning: )

A series of screenshots with steps along the way to show what I did using the Windows Problem Steps Recorder (http://www.hanselman.com/blog/HelpYourUsersRecordAndReportBugsWithTheProblemStepsRecorder.aspx)
AND the .skp model used is inside the zip too (I’m limited by this forum to only a single attachment… :frowning: )
StepsToReproduceUnionSketchupIssue.zip (1.1 MB)

This seems similar to this other problem described on the forum (Union of 2 solids causes one or both to disappear), but with the .skp file attached, hopefully this is enough to explain it.


#2

Here’s the “before” picture

and here’s the .skp file on it’s own
WaterBottleTopv4-2.skp (1.3 MB)


#3

Is the chamfered hole important? It will cause you problems as it is.


#4

the original object I’m modelling does have the chamfered hole, so I’d want to keep it if at all possible. Why do you think it will cause problems?


#5

Have you tried scaling the model up before doing the union? You are working dangerously close to SketchUp’s well-known limit for creating small geometry. When I do that I get no obvious issues other than some remaining cleanup:


#6

this is what I wound up doing and it worked for me, thanks for the pointer!