Union of 2 solids causes one or both to disappear


#1

Occasionally, I run into a problem where using the union command causes one or both of my two solids to completely disappear. The most recent case involved a simple cylinder that I was trying to union or merge with a more complex solid that was perpendicular to the cylinder.

Both of the two individual pieces are perfect solids (SU shows them as a “solid group” or “solid component”). Yet the command results in something more like a subtract. Anyone have an idea of what is going on?

BEFORE…

AFTER…


Unioning two solids results in one disappearing (kind of)
#2

There’s a whole lot of missing information. Maybe you could clarify? Maybe give us some images or a special file?


#3

Some more information. I saved the file with the 2 solids, closed SU, and restarted SU. After the restart, the union command works as expected. However, the restart sometimes gives the same result so it does not always help.

So, it is a bug or some kind of temporary setting that I am unaware of.


#4

Still not enough information to determine if it is a bug. It’s kind of like saying, “I sneezed. Does that mean I’ve got the flu?”

How big are these solids?

Perhaps you could share the SKP file?


#5

Dave,

Unfortunately, the problem occurred on my day job. I had to keep going and
I no longer have the file. In any case, I am fairly sure that I found the
root of the problem.

I was basically running into the wall of SU’s accuracy, which I have read
multiple times is about 0.001". The geometry was fairly small with
detailed curves. Rather than doing a union, I exploded my components and
stitched everything together manually. After making it all the geometry a
component, it showed up as a solid.

It is a divergence from the topic, but for the full history, I imported a
vendor’s solid from .DWG file that came in all fragmented. I work with
parts from multiple vendors that use ProE, so they have to do a translation
to .DWG for me to input into SU. Sometimes the various translations work,
other times everything is fragmented. When it is fragmented, I have tried
importing on a meter scale (rather than inches) to see if it comes in
clean. It doesn’t so I am unsure of the cause of this problem.