Bug Splat on union of two solids


#1

Not sure if this is a bug or what, but I have two solids and keep getting a bug splat when I try to Union or Outer Shell the two solids in the file.
I tried scaling to 100 and it didn’t solve the problem.

rad_test.skp (1.2 MB)


#2

Even scaled at 100x there’s a tiny misalignment that I expect is the culprit.

Screenshot%20-%201_1_2019%20%2C%203_16_55%20PM

The other end looks fine.

I’m curious about how you drew that part of the grate and why you have that misalignment.


#3

Do you have any idea(s) why OP’s Solid Tools commands, would result in a bug splat rather than an incomplete command execution, with the noted misalignment?


#4

Only a guess that some bad geometry is resulting from the misalignment. Someone with access to the Bug Splat reports could tell more if the OP is sending them in.


#5

Thank you. I will keep in mind if I run into a similar situation.


#6

Misalignment fixed. Keep getting bug splat.

No idea how the misalignment happened. That part of the grid was designed by duplicating one straight piece and two curves, as many as required.


#7

your model doesn’t ‘splat’ on [my very] old iMac…

how are you running SU v16 on Linux Ubuntu 64 bit…

john


#8

Yes and no. I’m Ubuntu 64bit running sketchup in Win 7 on Vbox…


#9

How do you see the machine i’m running on ?


#10

He can’t actually see your machine, but in your forum profile you said that’s what you are running.


#11

I took a look at the crash database for crashes with your name on them, but didn’t see any. Are you able to submit a crash report? If so, put “Gumbo” in the user name field and I will be able to see it.

Thanks,
Marc