Unhide showing all faces

Hi, I did this:

  1. hid a surface, so I could remove some internal geometry.
  2. Edit > Unhide > Unhide all. Surface does not show
  3. View > Hidden Geometry. Surface and all its components are shown.
  4. Select hidden surface > Edit > Unhide > Unhide Selected
  5. View > untick Hidden Geometry. Surface disappears

Any ideas how I can make my surface show again, please?

It would be easier to identify the exact fix if you share the file.

Unhide only works in the current context. If the component in which you hid the face isn’t open for editing, Unhide won’t affect the face. You need to open the component for editing and then use Unhide.

Thanks Dave. I have attached the file. The hidden geometry is part of the Half Handlebar component, which I drew as part of this file.Animation 2.1.skp (2.7 MB)

So as I described, open the component for editing and choose Unhide All. Or, turn on Hidden Geometry (View menu) open the component for editing, select the hidden geometry, right click on it and choose Unhide. I have a keyboard shortcut for View>Hidden Geometry which makes quick work of it.
unhide

Brilliant, thanks Dave.

1 Like