Unexpected File Format problems

Hi Everyone!
Am having an issue opening up my SketchUp file 2019 after working on it for 4 whole day. The error that am confronted with is ‘Unexpected File Format’ and then it just crashes.

I’d be very grateful if someone would be able to help me opening the file.

Copy and paste this path into File Explorer:

%LocalAppData%\SketchUp\SketchUp 2019\SketchUp\working\SKETCHUP\RecoveredFiles

Are there any files in there? If you see the file you have been working on, copy it out to another location, then try opening that copy.

If that all fails, upload the file somewhere and reply with a link to the file, so I can try to fix it.

Hi Colin,

Thanks for replying to me on this issue. I tried doing those steps but to no luck.
So, here is the link for you to try your expertise on opening up this file.

Thanks again!
Nikita

Hi Colin,

Were you able to open the file from the link I sent you yesterday?
Thanks a lot for your help:)

That was late in my evening, and I hadn’t seen the message. I’m getting the file now, which is one of the biggest file ever made in SketchUp.

Slightly exaggeration, but it is a big file, and is taking some time to download.

1 Like

I tried with my Windows 10 setup running under Parallels, and ran out of memory trying to work on the file. But, I do happen to be receiving a real PC today. When I have that set up I will try again.

Hi Colin,

No worries! I’ll wait until tomorrow evening then to hear again from you on this?
I really appreciate your help on this.

Thanks!
Nikita

Don’t know when the PC will arrive, it shows as being by 9 PM, but it’s already on the truck. It’s 9:18am for me now.

1.8GB is HUGE for sketchup. I’ve never worked with a file bigger than about 800MB, and to even open that, with many layers/tags turned off, could take up to 20 minutes.

If you can get any earlier version of the file to open, is it possible to reduce the file size, either by purging unused components and materials, tags, etc, or by using low-poly proxies for over-detailed components such as furniture, or smaller textures? Or by splitting the model into smaller ones?

Hi John,

I do not have an earlier version of this file unfortunately to reduce the file size.
There are many SketchUp components like furniture etc. used in this file which makes the file this heavy.

I’d really appreciate your help on this if it could be opened without reducing the file size as it doesn’t seem possible from my end.

Thanks!

Not even an out of date backup file?

The best Colin is likely to be able to manage is to rescue the components, in the light of what I’ve seen from his previous posts.

Groups would be lost. Much or all of your model would be lost. Really sorry…

But wait and see what @colin can come up with - you may do better than I fear.

I’ll send you the backup file which I renamed and changed to .skp.

Here it is:

This also fails to open though:(

Don’t send it to me - I’m unlikely to be able to open it at all on a five year old iMac.

See if you can open it yourself, and at least try Purge - do that via Model Info/Statistics/Purge unused.

If you saved the file with either or both of Outliner or Component browser windows open, it will take even longer to open.

You could try opening a new file, setting those windows either minimised or better, closed, then try Importing your backup renamed .skp file. And THEN try Purge unused via Model info - it would take an AGE for the Component browser window to open and fill.

Steve Baumgartner (@slbaumgartner) has an extension called Entity Counts which will check a model for the ‘heaviest’ components in terms of edges and faces. It’s now in either Extension Warehouse or SketchUcation plugin store - sorry, I can’t remember which. Probably the latter.

Just seen your upload.

Does it give the Unexpected File format message, or just take forever to open? Wait, if it’s the latter.

And no file history copy, or earlier saved or backed up version?

Unfortunately no other backups. This also gives the same error ‘Unexpected file format’.
Am not able to open the file and hence wont be able to purge or reduce the file size.

Thanks!
Nikita

It’s a while since I used Windows 10, but isn’t there something called File History? That might have preserved an earlier working copy, but I don’t remember enough about how it works to know if you have any chance of recovering a previously working copy of your file.

Otherwise the best I can think you will recover, if Colin has any success, will be the components you had made in the file or included from the 3D Warehouse.

I tried my best to look for file history but it doesn’t save the backup files anywhere. There was only one file .skb and that too doesn’t open and it shows the same error again and again.

:anguished: :anguished: :anguished:

Don’t worry, the entire file recovered this time. Here is the full file:

I did do a test of purging unused items. It took the file size to below 440 MB. But the one I posted is still at 1.7 GB.

1 Like