Unexpected File format -- Model built in 2013


#1

Hello, I built a model back in 2013 and thought that I had a solid backup of the file. Since then I have gotten a new computer and was going to show a friend my model so I downloaded Sketchup 2016 and tried to open my file but I received the unexpected file format error. I then uninstalled sketchup 2016 and tried downloading sketchup 8 but that didn’t work either. Lastly I downloaded sketchup 2013 and was actually able to see preview of my model but when I tried to open the file I again got the unexpected file format error.

I tried reading through some of the forums and i think that I might have layers in my model so maybe that’s causing an issue but at this point I don’t know what else to try.

Thanks,
Jeff


#2

Unexpected file format errors occur because the file has somehow been damaged, not due to version differences in SketchUp. If you try to open a skp file with a different version of SketchUp you will get a warning message about the version difference, but not the unexpected file format. Using layers should also be irrelevant as they have been in SketchUp for a long time.

If you can share the problem file, someone here may be able to help sort out what is wrong (or at least confirm that it is hopelessly mangled). If it is <3MB in size, you can attach it directly to a post (use the button that looks like a little bar with an up arrow at the top of the reply window). If larger, you can upload it to a file sharing site or the EW and provide a link here.


#3

open a new empty model, turn off shadows, and any ‘fancy’ styles…

close all the support windows like Layers and Outliner and then try to ‘import’ your model into v16…

if it comes in clean it up and purge unused before re-saving…

john


#4

My file is 8.7MB so here is a link to the file.

https://drive.google.com/file/d/0B11uCh57DpQiellSUzJYd043c2M/view?usp=sharing

Thanks for looking,
Jeff


#5

not even importing into a clean template on my mac…

invalid file…

john


#6

Ok. Thanks for trying.


#7

I also couldn’t do anything with this file. Maybe one of the Trimble developers can fix it…