Unexpected File Format after saving and reopening a .skp file

Yes, I can try.

Hi Colin,

Thanks for getting back to me, I have 3 file formats that are listed but cant seem to upload.

I have uploaded to wetransfer and you should be able to access them though the following link.

If this is not acceptable please advise.

As usual, I only recovered the components. There won’t be anything in the scene, but the file includes 4,546 components.

Thanks Colin that’s very helpful.

Any Idea what caused this to happen? all files that I was working on were on the local drive not network or external drive.

Thanks

URGENT HELP REQUIRED! Submission in less than 24 hours! Same error, is it possible to recover components?? @colin

See my reply here:

Hey, @colin I’ve encountered a similar problem. I would really appreciate it if you help me recovering this file. Thanks.

The model seems to only have a few dynamic components in it, and a few people recently have had the same components in their file. Are you following a course, where many people are doing the same exercise?

I could only recover the components and materials. Here’s the file:

2 Likes

Hey, @colin I’ve encountered a similar problem. both my SketchUp and auto save files arent opening due to this error. I would really appreciate it if you could help me recover this file. Thank you.

Autosave file Recovery

I think most components and materials are recovered, but the scene is empty:

Hello sir, could you please help me recover my file its pretty small (1M) but very important to me, thank you so much!!

I tried the file, but unfortunately most of the file is empty bytes. There isn’t anything in the file to recover.

1 Like

Good day Sir. Can you also try my file? I’ve saved it just yesterday without any problems popping up but now it says “unexpected file format”, same for the skb file even if I try to rename it to skp. Please help. Thank you.

I think that I didn’t remover much. Lots of tags, and a few colors and components. You could let me try the SKB as well.

here’s the skb sir. but unfortunately for this skp file that you’ve recovered, i opened it and the model is empty. thank you.

That came out about the same.

I will ask the developers to take a look, because you have a lot of non-Roman characters in the file, and if that is affecting anything, it would be useful for us to look into the problem.

It’s late evening now, I won’t hear from my colleagues for about another 12 hours.

oh i see. anyway for now, thank you very much sir.

hello there i am also facing same issue , i saved my file and closed it and then while opening it shows unexpected file format error
i have uploaded both skp and skb files
please help me
much appreciated

As usual, I only recovered the components and materials, and there’s nothing showing in the scene.

I recovered both files, and they are both here:

You might as well use the one called SITE_recovered.skp, it’s bound to be more recent than the other one.

Hi Colin, could you help me with this file? After saving it in a external hard drive it became corrupted.

Here is the link: https://we.tl/t-5ls5GxYyxe

Thanks in advance