Unable to Scale Layout Document for printing


I set up a construction drawing in LayOut that is 16 1/2" wide x 11 3/4" high (A3 Format) so it’s the correct size for my contractor.

I would like to print it in a letter format (only format my printer can accept) for proofing but
1/ the printer pop-up window will not let me Scale to Fit Paper Size and
2/ when I convert the document into a PDF, it shifts the SketchUp model while all the notations remain in the correct place. I can’t even save the PDF in an A3 format to bring to a print shop.

Any idea why this is happening and how to remedy it?

Thank you

Don’t print directly from LayOut. Export from LayOut to PDF and then in Adobe Reader’s Print settings, set it to Fit.

Here in LO I have a thing on Arch B paper.

In Adobe Reader I’ve selected Fit under the Size button so it’ll fit on 11x8.5 in. paper.

1 Like

Thank you for the suggestion @DaveR

I tried it but it doesn’t work. The same issue happens. The model shifts but the text remains in place.
Could it have to do with settings in the SketchUp model itself?

More likely it has to do with settings you made in LayOut.

Did you add the text in the SketchUp model or in LayOut? It would help if you’d share the LayOut file so we can see exactly what you are working with.

All the text and dimensions were done in Layout.
I attached the file.
Thank you!
LayOut Forum help.layout (15.1 MB)

I see what the problem is. It’s not the text that’s shifting, it’s the model view in the viewport due to incorrect setup in both SketchUp and LayOut.

Notice in the SketchUp Model panel you have the viewport rendered as Raster. The Camera is set to Perspective (Ortho box unticked and Scale grayed out are the clues.)

In Document Setup>Rendering you have the Output Override box checked. This means that as LayOut is outputting the PDF it is rendering the viewports has Hybrid.
Screenshot - 5_18_2024 , 8_25_51 AM
The same sort of shifting will occur if you choose Hybrid (or Vector) rendering in the SketchUp Model panel.

It might be that @adam could comment on this shifting. It probably shouldn’t occur. But you could avoid that anyway. For this file, untick the Output Override box before exporting the PDF. Here’s what I get for the exported PDF after unticking the box.

LayOut Forum help.pdf (267.9 KB)

It looks like you’ve put a lot of time into this file. If it is basically finished as it is, I would suggest leaving it alone but going forward, I would urge you to set things up correctly and save yourself a lot of potential issues. More on that in another reply.

You should spend some time learning how to use SketchUp and LayOut the way they were meant to be used. It would save you a lot of problems and potential hair loss.

You should be creating scenes in SketchUp to show the model as you need to see it in the viewports in LayOut. In the file you share you haven’t done that. You are using the Last saved SketchUp View for the scene. Think about what those words mean. When I opened your SketchUp model this is what I saw. That’s the Last saved SketchUp View. Actually it may be different on your end since you might have changed that view since saving the LayOut file.

You’ve then modified the Camera position and zoom levelto create the view of all those different elevations from your imported CAD file. If the Reset or Reset All button gets pressed, you’ll have a mess. Here’s what happens in LayOut when the Camera for both viewports is reset.

The correct way to deal with all of this is to set up a scene in SketchUp that shows what you need to show in the viewport. For these elevations set the camera to Parallel Projection before creating the scene so you’ll be able to set a scale for the viewport once you get to LayOut.

In LayOut select the appropriate scene in the Viewport section of the SketchUp Model panel and choose a scale from the dropdown list that is suitable for the size of the paper you are working on. DO NOT double click into the viewport to edit the camera position or zoom level. If you need to adjust the size of the viewport for the page, drag the edges or corners of the viewport after you set the scale. Don’t do anything that results in the Reset button being displayed in the Camera section of the SketchUp Model panel. By following that you won’t have your dimensions and labels getting all screwed up.

I’m curious about your general workflow. Are you drawing up the elevations in CAD before importing them into SketchUp? If so, why import them into SketchUp at all? You could import the CAD file into LayOut directly.

Do you wind up making a 3D model of the project? If you do, you could make your elevation and plan views as scenes from the 3D model and forego the 2D CAD drawings altogether.