Layout PDF Export is resizing drawing and changing scale

print
printscale
scale
printing
export

#1

I use Sketchup pro 2015 for construction document drafting and Layout for labeling, dimensions and markup. I commonly export these drawings from Layout in PDF format to then share with clients and to send to my printing company for larger format prints.
I just recently realized that when I export as a PDF the scale of my drawings is being changed as pointed out by a client. I have spent hours trying to find some way to correct this including searching the forums.
Can someone please help???


#2

Are these plan or elevation views?

The most common reason for the scaling to be off in the printed PDFs comes from the printing setup. Usually the user has “Fit” selected instead of “Actual size”.


#3

For some obscure reason “Fit” is the default Adobe Acrobat print setting. Note that even if the original page size is the same as the paper in your printer, this setting will shrink it to fit within the printing margins, thus creating a printout with double margins.

Anssi


#4

I wonder if that “default” can be changed by the user. When I made that screenshot I just opened Reader and hit Print. Actual Size was already selected.


#5

Acrobat remembers the last used setting. It’s just that many people print things mainly containing text, and might not notice at all the slight reduction in size.

Anssi


#6

I am not speaking of using Adobe to “print” or create a pdf. My problem occurs when exporting a pdf using Layout and then printing


#7

To get a drawing from a PDF file to paper, you have to use Acrobat, Adobe reader or some other PDF viewer to view and print it.

The LayOut PDF exporter has no scaling options and it always exports full pages to full scale. So the aberration is happening elsewhere. Either your SketchUp views on your LayOut pages are not to scale or they are using a wrong scale, or then the scaling happens when the PDF file is sent from the PDF viewer to the printer.

Are your SketchUp views using Parallel Projection? If they aren’t, they cannot be to scale.

Can you post a simple LayOut file that displays this problem?

Anssi


#8

I would be glad to share a drawing here, tell me how


#9

Upload the LayOut file. click on the 7th button from the left in the row above the message window.


#10

The first document I attempted to upload was too large. Here is a simple rectangle 48’x32’. I have the same result when I export as PDF, it is not to scale.print test2.layout (109.9 KB)


#11

print test revised.layout (210.9 KB)
Try this.

You need to set up the camera in SketchUp to Parallel Projection and make sure the viewports aren’t modified from the original scenes.

I added a 6 in. long line drawn in LO for reference.


#12

Dave, First off thank you for your help thus far. My views are set to Parallel projection. I did the same with the 6" line in LO. the drawing should export 1/8"=1’ scale meaning the 6" line should exactly the math the 48’ side of rectangle.
I experimented and printed this through NITRO PDF trial version and it prints perfectly. However when I use adobe, the basic free version that came with windows ten the scale is still how.
Here is the weird thing the print interface has no options for scaling or “fit” or “actual” size as previous versions did. I am not really interested in paying $160 to get a drawing from PDF to paper without interference, more importantly I can’t expect my clients to simply so they scale a drawing when cost estimating.
Would mind printing the attached file to paper using the software of your choosing and checking the scale?print test3.pdf (22.0 KB)


#13

Maybe they are in your big file but the viewport in sample LO file you uploaded wasn’t

If it prints perfectly in NITRO PDF then this isn’t a LayOut problem.

I just printed your PDF in Acrobat Reader DC and it printed perfectly to scale. The 6 in. line is exactly 6 in. long in the print out.


#14

Dave, I had corrected the view on that on last version I sent I thought?


#15

A dumb Question… where in LO can you see the views ?


#16

The viewports in LayOut are named with the scenes you create in SketchUp. You are making scenes in SketchUp, right?

You can see which scene is selected by looking at the SketchUp Model inspector window in the tray which is normally displayed on the right side of the LayOut screen.


#17

Sadly I guess I am not making scenes. I am manually slecting the view of my sketchup model in LO


#18

That is making things difficult for you, then. The right workflow would be to create scenes in SketchUp and use them for the viewports in LayOut. Avoid opening the viewports in LayOut to zoom, orbit, or pan because that will cause the viewport to become disconnected from its scene in SketchUp.


#19

Gotya. I will take the time to learn about scenes. I am an old autocad guy who came to sketchup for occasional use about 5 years ago. These days I almost exclusively draw 2d floor plans for construction purposes.


#20

Something about Scenes