Uable to run Sketchup 2020 & 2021 : RAM and Graphic Card are not recognized

Hi,

I have a new pro computer, just bought with the purpose to run sketchup and Solidworks.
I also already have a pro SU license.

Here is my laptop properties :
windows 10
Nvidia T600
16 RAM

I tried everything, both with 2020 and 2021 (pro) :

  • linked nvidia to SU (through nvidia panel)
  • run as administrator
  • download last nvidia pilot

Here is what SU checkup tells :
- Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and/or graphics card memory to fail.
Error: Your computer’s system RAM is 0 MB. SketchUp requires 2 GB or more of system RAM.
Error: Graphics card information is missing.
Warning: SketchUp has detected you are using a “Intel(R) UHD Graphics” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!

Nothing work, do you have any idea what’s going on ?

Thanks a lot for your advices, i’m really stopped in my work, that a huge problem.

Did you install SketchUp correctly? That requires right clicking on the downloaded installer and choosing Run as administrator. If you didn’t do that, do so now. Then choose the Repair option.

New computer? Go to the Nvidia site to download and install the latest graphics drivers for your graphics card.

Right click on a blank part of the desktop and open the Nvidia control panel and make sure that your Nvidia card is set up to display SketchUp.

I wasn’t terribly familiar with the T600 so I looked at several benchmark sites. It appears to be a fairly low performer compared to the Nvidia graphics cards that are more commonly recommended. These days that’s GTX10xx, GTX20xx, etc.

Thanks for your answer.

Yes I did install the version as administrator.
And also repeat the action as yo said (that didn’t tell “repair option”) then it said same problem about nvidia thing : “L’accélération matérielle n’est pas prise en charge ou a été désactivée sur votre carte graphique. SketchUp a besoin que vous utilisiez une carte graphique accélérée.”

Yes, new one. I did install the latest driver.

Yes, I associated Nvidia to SU through Nvidia panel.

Yes, i agreed about the low performance of this graphic card. But apparently it can run it (not at its best certainly).

This is a known bug with the Microsoft tool Checkup is using to get system information. I wouldn’t really bother with the Checkup application. Install SketchUp, check the 3D application settings in the Nvidia control panel and try starting SketchUp.

Another thing: Are you using an external monitor? There are some laptops that only use integrated graphics with external monitors.
Are you using a dock to connect an external monitor? Some docks, too, refuse to run OpenGL - you might try connecting the monitor directly to your computer.

2 Likes

Thanks I already tried to adjust the 3D application settings in the nvidia panel.
I think it is ok, but who knows…

Oh. Yes I have an external monitor, linked ton my laptop with dock…
I try your idea, I 'll tell you.

THANKS !
Dock was the problem !
That’s ok now, thanks !