Typing a distance does not work


When I use push/pull and type in the measurements in the distance box, it do not follow the command, it is still on zero. The units is set to millimeters. Hope anyone have an answer to this problem. Thankful for help.
typing distance not working.skp (185.9 KB)

Just to confirm how you are doing it,
click and release to start the pushpull action, move the mouse any distance, let go of the mouse and type the distance you want(without clicking in the box) and hit enter to complete the action.

I am doing just that, but it doesn´t work

Can I ask you to try it in the file I sent, and if it works it must be somethng wrong with my sketchup software. It is sketchup pro 2022, and it worked before

I tried the file before I replied, there is nothing wrong with the file.

Ok thank you, then it is software problem. Is there any settings in sketchup I have to change and in that case where do I find it?

Reboot your computer and check that your keyboard is working correctly. There are no settings to change that would relate to this.

I have done that now and my keyboard is working correctly because when I type the digits they appear in the box. Can it has something to do with I upgraded the drivers for graphic card and after that it did not work.

An updated graphics driver does not seem to me a likely cause of this issue. Can you try disabling all extensions via the Extension Manager window, quitting out of SketchUp, and then try the push-pull operation in a new model?

One other thing to confirm: you are pressing Return/Enter after typing the digits? Can you given an example of what you type? If you are using a fractional value or an unrecognized units string or a decimal point character that is not recognized for your computer’s locale, maybe that is the issue?

Check the status of your NumLock key it can affect the ability to enter numbers sometimes if you have a separate keypad for numbers on your keyboard.

Maybe try Model Info → Units then disable Length Snapping.

I tried you file and it works OK with SU 2022.

Make sure that you enter fractional dimensions like 1.234 or 1,234 using your regional settings.

On PC, SU treats the dot on the numeric keypad as dot, So, if you use comma as decimal delimiter, you will get a message that the entered unit is invalid since a dot will be entered. If you use a dot as the decimal separator, there is no problem. On the Mac, this problem doesn’t exist, I type a dot on the numerical keypad and I get a comma.

That must be a regional setting. On my Finnish keyboard I get a comma. It is even printed on the physical key.

I can use the “,” or the “.” in the measurements window. US kb layout.

What is funny is that Excel treats the dot on the numerical keypad as a comma but SketchUp doesn’t.

Why ?

Language settings? Or is it a MAC thing?

I seem to remember that you are a French Canadian. Are you using some specifically French Canadian regional settings? Have you tried some different ones, like French?

I use the comma as the decimal separator and the semi colon as the list separator. My Keyboard is a QWERTY french canadian keyboard. It has some accentuated letters like à è é ù but that should not be a problem.

The strange part is that on my work PC, if I press the DOT key on the numeric keypad, I get a comma with Excel and a dot with SketchUp. So, to get correct decimal numbers with SketchUp, I have to use the comma on the main keyboard which make the use of the numeric keypad a real pain.