Trying to join 2 washers together into a strip


#1

Hi… I am sure this is an easy question, but I can’t work it out.

I recently made some spacers (basically 3.2mm thick, 8mm washers with a 3.5mm hole)… But I have figured that they would be more useful if they were joined together, in a ‘strip’ (basically a long oval, with holes in each end, 32mm appart).

I figured this would be easy to make, so I did this.

  1. Made some guide lines 32mm appart
  2. Drew an 8mm circle with the hole on one of the guide lines
  3. Drew a 3.2mm circle in the middle of the first
  4. Repeated this on the other guideline

My plan then was to draw lines between the 2 sides of the circle, erase what was left and the “push” this up to the thickness I need…

But when I draw the lines, they do not quite hit the wides part of the circle… And when I try and erase the remains of the first circle, it only deletes little bits at a time… Finally, when I push the whole thing up, the curved part at the ends, it not smooth like it is when I make a “washer”.

I am clearly doing something very wrong and have no idea where to start… Could someone give me some pointers?

Jon


How can I increase the accuracy of my torus's geometry?
#2

Your basic plan is sound, so it would seem your problem is in the execution.

A couple of tips:

You don’t need the guidelines. Just use the Move/copy command to place (move) the second set of circles the requisite distance from the first.

When you draw the lines connecting the two circles, you must snap to the cardinal points on the circles. Wait for inferencing feedback before you draw these lines. You should get a green dot and the tooltip Endpoint before you click the ends of the lines. You must always wait for inferencing feedback every time you click the mouse to draw anything, No exceptions. If you don’t get inferencing feedback, you will not hit the intended endpoints, as apparently happened.

Don’t ever draw the same thing twice; that’s a waste of time. Draw it once and copy it.

-Gully


#3

The only thing Gully has not pointed out for you , is to make sure you draw your circles ‘on axis’.
Watch the colours that show on the radius of the circle. Red and green are on axis but black is off.
If you are off axis the endpoints wont line up properly.


#4

Awesome… I am trying this now… I do love you guys for your help.

  1. Move/Copy… Great tip. I tried doing a copy/paste and the copied object was made of poligons… But now I have just looked at the move feature and can see the “CTL to copy” at the bottom… Have you worked out I am a novice yet.

  2. Deleting the holes… How do you do this?.. When I make ‘washers’ I always use the pull tool to push the center down until it deletes… I have never managed to work out how to make get rid of the center using the eraser…

Update: After watching the video, I realise you can selected and delete it… Doh!! That was obvious…

Other than that, I did exactly the same as you… But I wonder if this is all down to getting the axis right from the start…

Going to give it a go now… Cheers…

Jon


#5

Delete: click once to select, hit [del]
(or r-click menu)


#6

Maybe a brief click on a face with the eraser should do the same as select/delete? I know that the way it works now, where you can drag around a face erasing lines is good, in that the face doesn’t get erased, but if you do a brief click on a face with the eraser, what else were you trying to do, other than erase that face?


#7

OK… So I am making progress… And thought I had it nailed… Once I finished the flat shape, I was able to delete the semi-circle that left on the original washer… But when I tried on the other end, it only deleted little segments of it…

Must be doing something wrong… Could you explain the step to me where you move/copy the object… But before you do it, you move the mouse down to the red axis. I always struggle with that bit.

In my case, I simply moved the copy out and made sure the line was red, so assume it was fully on-axis.

Jon


#8

Its getting worse… I tried again, and now I am in exactly the same position as before… When I try to delete the inner semi circles, they delete in segments… Once I managed to get it right at ONE end… But now its broken at both.

I am making sure that all my lines are drawn “On axis” (i.e they are red rather than black) but I still get the problem.

OK… Breaking this down into something really simple… I can reproduce the behavour over and over… .

I am doing this…

  1. Draw a circle (any size) on the green axis
  2. Copy/Move it a random distance (keeping on the red axis)
  3. Drawing lines… Waiting for the “enpoint” tip to appear first.

But now when I try to delete the inner semi-circles, they delete in segments… And when I push the shape its covered in lines, rather than being a nice smooth fill

I am clearly missing something REALLY obvious here.

Jon

Edit: I suspect I am not selected the absolute top/bottom of the circle when I draw the line… How exactly do I select that… If I hover around the edge, it always shows “Endpoint”… But I need to select the point which is the absolutely inline with the 2 circles…

I have tried hovering over the center and then moving to the outside edge… But it still doesn’t help.


#9

The legendary pool player, Steve Mizerak, said it best: The secret to success is “practice, practice, practice.”

-Gully


#10

Here’s another way you may find easier, although you need to get where you can do it either way blindfolded. (Alright, forget the blindfold.)

-Gully

Edit: Oh, I guess the rectangle is 32mm long.


#11

I dont mind practicing… I just dont know what i am doing wrong… I have tried everything and i just cant work out how to get the lines drawn…

I know what the problem is now… If i measure the circle, its 8.00000mm… But if i measure between the lines its a fraction of a mm less… So i cam clearly not selecting the furthest most point on the circle and it cant be this hard. I must ge missing something,


#12

Take advantage of the dynamic environment. You can orbit and zoom using the mouse scroll wheel as you draw, so wheel your point of view around until you can positively see your target. Work close to the axis lines so you can refer to them–they should help you identify 12:00 and 6:00 on your circle. And when you do draw the line, make sure it stays on axis (lights up in the color of the axis to which it is parallel).

-Gully


#13

The size of the object you are drawing is somewhat small, and it seems to me that you may be falling victim to SketchUp’s well-documented nearby vertex tolerance. You haven’t said how many segments are in the circles you draw, but at a small size it is possible that more than one of them is “close enough” to being on the red axis from the start of your line that the inference engine will accept all of them as being on the axis. Its a bit difficult to see in the attached because of my high DPI display, but if you watch closely you will see multiple endpoints flagged while the red axis highlight is still on, and only when I get pretty far away does it go black. The workaround, as usual, would be to scale the geometry up before doing the operation, and then back down to real size afterward.


#14

Ahhhha… I think you are onto something there… I just did a test with a 100mm circle and had no trouble drawing my lines, so what you said makes sense.

On thing I should point out is that when I draw circles I do “96s” just to get nice clean circles… I know its uncessary for something so small, but its a habbit I have got into.

Perhaps this isn’t helping?

Assuming I was to do things at scale, whats the process for reducing it… Do I just do things x10 bigger and then reduce? How exactly do you reduce the scale getting it back to the correct size with 100% accuracy?

I will have a little search/play with the scale feature and see if I can work it out.

Jon


#15

Thats done it…

If I lower the number of segments down to something less (ie 16) I was able to draw lines at the right part… But under close zooms, the circles arn’t very smooth… But at the end of the day I am printing them at this scale, so I am hardly going to notice.

I then drew the same thing (using 96S for the circles) at x10 scale and easily few the object I wanted… And reduced it afterwards to 0.1 to get the size I wanted.

So this was simply down to the fact that I was working at such small scale…Looks like I need to read up on Sketchups limitations.

Thanks for your help

Jon

Edit: After a few more attempts, it seems impossible to draw lines between to circles at this kind of scale, unless I use a really low number of segments on the circle… So the ‘scale’ suggestion is possibly the only way to do what I want…


#16

One of the worst habits you can get into. I suggest you break it forthwith.

What good is a “clean circle” if it makes your model into an unwieldy, overweight, under-performing dog (my apologies to any dogs in earshot)? In SU, less is more, and “clean” means free of excessive, unnecessary geometry, just the opposite of what you’re doing. The difference in appearance between a 24- and a 96-segment circle may be hardly noticeable on an extrusion whose edges are softened anyway.

Get used to using the default number of sides. Look for opportunities to reduce the number of sides, not increase them. You should have a compelling rationale for increasing the number of sides. A “cleaner looking” circle is not a compelling reason.

The main exception to this philosophy/practice is 3D printing, in which the quality of the actual surface does benefit from more facets, although the disadvantages in terms of model size and susceptibility to error persist in any event.

Look up scaling objects based on a known dimension using the Tape Measure tool in the Knowledge Base.

-Gully


#17

As well as using a reasonable size when you are drawing and not overly segmenting your arcs…
Check your Model Info > Units > Snap length is NOT set [i.e. ticked]
This might cause issues…Otherwise all for the earliest advice is very sound.

A simpler approach avoiding many of these issues…
Draw a flat rectangle, typing in NNN,NNNN for the two dimensions.
The long side being the distance between the circles’ centers, and the short side being the 2xradius of the end half-circles.
Then draw a circle centered on the short end, snapping to the rectangle’s corner.
This works irrespective of the circle’s segmentation.
Repeat for the circle at the other end.
Repeat for the inner ‘hole’ circle at both ends - centered on the end edge, and ensuring you snap onto the rectangle’s end line too.
Now erase the unwanted parts of the larger circles now overlaying the rectangle, also erase the ends of the rectangle, now overlaying the ‘holes’ and the face you want to remain as one piece.
Now select the faces in the ‘holes’ and [delete] them
Now you should have a single face.
It should consist of a rectangle adjusted to have rounded ends and two holes punched in it.
Use PushPull on that face to extrude it into a 3d object…


#18

Cheers. The only use I have for SU is 3D printing… And the default circle segments are visible in the print…

I guess I don’t need to go to 96 segments, but it seemed like a nice round number… And I have very little to worry about on the performance front as all of my models so far have been mind numbingly simple.

In this case, going to 48S or even 24S doesn’t help. The only way I can draw the lines correctly is when I use a very low segment count… But then these would be visible in final print.

So I think I need to explore other ways of doing this, and scale could be one of them.

Thanks for everyones help with this.

Jon


#19

That would have been useful information for you to provide up front, since it represents a major branch in the road insofar as modeling strategy is concerned (indeed, it turns much of the conventional wisdom of modeling with SU on its head), and it probably would have saved us all a bit of time and effort. There happens to be a 3D Printing sub-section in this forum category, which would have been a better home for this post.

-Gully


#20

For 3D printing of circles, I came up with a calculator that computes the number of sides based on the radius and the maximum deviation you want for the arc. For example, 0.025mm is a reasonable tolerance to use; for a 8mm diameter full circle, you would need:

Use 32 sides (using the next largest number that is evenly divisible by 4 will insure the primary cardinal points are present – i.e., 0 deg, 90 deg, 180 deg, and 270 deg).

For the smaller 3.2mm diameter holes:

Use 18 sides.

Following the previously outlined steps above, you can create the geometry directly without needing to scale it up and then down again.

The number of segments calculated above will give good results in any 3D printing medium that’s accurate on the order of 0.025 mm (0.001 in).