Trouble with kerkythea Extension


#1

Having read various articles and previous forum posts I have tried various things to get kerkythea up and running. These include creating my own Plugins folder (due to mine being missing) under Users/Library/Application Support (Mac). Also, creating a account to install another extension to try and make the extension menu appear, no luck there. I’m using SU Make 2015, what am i missing here? Thanks


#2

Type [or copy+paste] this into the Ruby Console +
Sketchup.find_support_file(‘Plugins’)
This will return the full and proper path to your default Plugins folder.
Copy+paste path that into the Finder to open the folder.
Make an alias of it, to make future access easier.


BUT for the last several years you do not normally need to access your Plugins folder…
Almost all Plugins/Extensions now come as .RBZ archives.
These can be installed using the Sketchup > Preferences > Extensions > Install Archive… button.
That tool has been available since v8.2…
The chosen .RBZ archive’s contents are extracted, correctly keeping its main code or helper files in its subfolders etc, the loader-script is then automatically loaded and then that tool is available in a menu, toolbars, or whatever…
If you get a Plugin which is in a .ZIP archive, then you can simply rename it with .rbz on the end of the file name, and it’ll auto-install OK as explained above…
A .RBZ file is just a .ZIP archive with a different file-type suffix.
If you get a simple lone .rb script that could be manually put into your Plugins folder, and Sketchup restarted to load it, OR - which is probably just as quick - “zip” it, re-suffix that .ZIP as .rbz, and then auto-install using that - then no need to restart SketchUp :wink:

#3

Thanks, had tried the Ruby Console before and the Install Archive. Read to load the .zip file into the Install Archive but it was never letting me select it. Changing the file to a .rbz worked a treat!