Trimble Visualiser help... pleeeease

Hi, Is there anyone out there who has successfully managed to open a Sketchup model in Trimble Visualizer? The icon for ‘send to visualizer’ is missing in the desktop app of Trimble connect… on mine & one other persons at least! Various models published & uploaded but simply no icon to send to visualizer. Has anyone had the same problem that I’m experiencing & did you find a solution? Sketchup team member help perhaps? Its part of the Pro subscription after all…

Never had issues myself, do you have more than one account on the computer?
Perhaps it’s a permission issue.
There used to be an msi for Trimble Connect for Windows, but it is an .exe now, I believe.
I would suggest deinstalling it and then reinstalling by rightclicking on the downloaded installer file and choose ‘Run as Admin’ .
Restart computer (cold reboot)
Open it first and view some models.
Close it and then run the msi of the Visualiser installer
See if that makes any difference.

I just had time to install visualizer. I didn’t have the Visualizer button at first but while watching @Speaker’s tutorial I understood a short sentence that indicated that you need to open Trimble Connect Desktop first, close it, then install the Visualizer plugin and reopen Trimble Connect Desktop. I closed TCD, ran the Visualizer installer again, and then opened TCD and the button was there.

Thanks, good to see that this method worked for others too. That is what I had read on TDC forum a year ago. But, now TDC team member made a correction that you have to install both first. I didn’t have second PC to test both variants.

I want to hear from others too - what method works for you? We need some more testing

1 Like

Thanks for help Dave but still no go my end. Uninstalled both Tc & Vis & reinstalled as per instructed but still no icon?
I have a bunch of what look like associated visualizer/Tc files. I think i’ll delete all & throw the towel in.

You should be finding the icon or button in the Trimble Connect for Desktop panel.

1 Like

This is what is happening, Icon shows for a nano second & then dissapears. Not sure how to attach a video so here is Amazon link.

When you installed Trimble Connect for Desktop did you right click on the installer and choose Run as administrator from the Context menu? If not, do that. Then do a cold reboot of your computer. Any change in behavior?

Should I uninstall & reinstall TC first?

No. Close it if it’s open. Find the downloaded installer, right click on it, and choose Run as administrator. If you are prompted, choose Repair.

Done & repaired, still no icon when opening? Sorry Dave, I’m not good with this side of things… dont even know what a cold reboot is…

Sorry. Power the computer completely off and restart it.

I’ll give it a go & let you know result… thanks for this.

No luck. I think it must be a software issue or something my end. Thanks anyway Dave.

Strange indeed! It all worked straight away when I installed the two a couple of hours ago.

Very strange, I can live without it… shame is all. Cheers again.

1 Like

Hi, could you send me your Trimble ID (the e-mail address of your Trimble account) and I can check if this is an entitlement problem. My e-mail is kim.nyberg … at …


Thanks… sent you email.

I see that you opened a project called ‘SketchUp’.
Usually, that comes with a trial plan. That trial plan is probably expired, so you need to create a new project, first.
In the project details, you now have it under your current plan (SketchUp pro includes a Trimble Connect Business plan)
See if that works.

Thanks for that Mike. Tried that but no luck. Trimble team have confirmed that it is an ‘entitlement issue’ & are working to rectify. Many thanks to you all everyone else input with this.