Trimble Connect file from desktop to ipad

I’m working on Sketchup on the desktop and the file is saved onto Trimble connect. I try accessing the latest version on the ipad. When I select the file, the date and time last saved from the desktop is correct. When the file opens, it is the previous version? Please let me know if this is usual? Or if I need to save as a new file name every time?

It should show the latest edits from the desktop.
Which version of SketchUp desktop do you use?

Occasionally, SketchUp for iPad needs to be reauthorized with Trimble Connect. You can force this by clicking on the Trimble Connect tab, waiting for projects to load, and then returning to the Home screen. At this point, SketchUp for iPad should correctly show the most-up-to-date version of all cloud flies.

Using Sketchup 2024

I tried signing out and then back into Trimble, but it still gives me the previous version file. I just tried it again with the desktop save to Trimble connect… and then turn around onto the ipad to open… still… it’s the previous version of my file.

Does it work the other way around? (edit on iPad, Save, open via the Welcome screen in Desktop)

Just selected “Make available offline” and the file opened up to the latest file.

Yes, saving from the ipad and opening the file from the Sketchup/Home/Trimble Connect did work correctly.

By the way, the small thumbnail image from the ipad Trimble shows the accurate file, but it’s when i open it, it’s the previous file. That’s the odd part.