Transparent style views rendering opaque in Layout 2017

And here is the same thing, version 2016, showing the desired effect.

Layered Plan Sample 2016.layout (174.7 KB)

I produced this file by saving the 2017 Sketchup model to 2016 format, and then recreating the layout in Layout 2016.

Interestingly, if I open this 2016 file in 2017, the countertop shows correctly. So now I know 2017 is capable of displaying transparent layers.

Another test: In Layout 2017, I saved the first file down to Layout 2016, and then opened it in 2016. The countertop is opaque.

And one more test: I created a 2017 Layout from the 2016 model. The countertop is opaque.

Yep. I’m seeing the same thing. I was experimenting with making the countertop material translucent instead of using X-ray but there’s no change. I’d say you found a bug.

I feel simultaneously lucky and disappointed. It’s like finding a four-leafed poison ivy. :slight_smile:

Thanks for the confirmation, Dave. Should I report this somewhere officially?

I get that!

I edited the top of the post and added the word “bug”. I expect we’ll see someone from the team chime in.

Thanks. For the time being, I guess my choices are to either revert to 2016 (but I sure do appreciate the improved Layout tables!) or to render the countertops in a wireframe style, which is not nearly as easy to read, but at least gives me all the lines I need for dimensioning.

Thanks guys for your comments and models. I am looking into this right now.

Trent

2 Likes

Hi all I have been able to track down the issue. This is actually a known rendering issue within SketchUp that is showing up in LayOut. Exporting the same image out of SketchUp to a 2d graphic with a transparent background the transparency will not be present.

The only work around would be to assign like a 50% transparency to the counter top material and have scene contain the counter top and the cabinet.

I know this is not ideal but it should get you closer to what you are looking for until we can get the fix.

Trent

Thanks for your attention to the matter, Trent!

That does work for the render, but it does have one drawback: I can see the base cabinets through the 50% transparent countertop, but I can’t snap dimensions to them. Which is true of the stacked system as well, but I can turn the countertops off to do my base cabinet dimensions.

@trent, thanks for the update. I got your other message, too. :wink:

@des, since this is a bug that is being worked on, I would look forward to a fix one of these days. In the mean time, how about a modification to your workflow? In SU, create a scene with just the cabinets (like in your example) and immediately after, make a second scene with the cabinets and the counter top displayed. In LO, initially set the viewport for the cabinets only and do the dimensioning. After the dimensions are in place, change the scene to the one with the counter top. It’s not perfect but it would be reasonably straightforward.

Yeah, that occurred to me to, after posting. As did another drawback: since I need the countertops to appear solid in elevations and perspectives (glass tops have still not caught on around these parts), I will need two copies of each one (solid and translucent), to be switched on and off in the various views as appropriate.

I am struggling with the same problem, but with a twist. In a LO document I have two viewports with different scenes from the same model. The two scenes show planes with the same transparent material, same Style, same raster render, same everything. I can find no difference in any settings between the two scenes and viewports. In one LO viewport the material is transparent, in one it is opaque. I am happy though, to learn I am not crazy. If is helpful I can upload the model and LO document. Thanks

Yes, it would be helpful to be able to try to see what you are seeing.

Anssi

Annsi- I will send you a Dropbox invitation. The files are too big to upload here.
Thanks, Brian

Anssi-
I sent you a Dropbox link. I am fine with sharing the files publicly, just not sure how to do so. In the LO file Page 2, the MODEL 1 layer is suppossed to be transparent, so the Model 2 layer is visible through, slightly toned down. Page 1 of the LO file is working fine with the same transparent material from the SU model. I have no idea, despite spending hours thrashing on it why this is not working. Perhap it is a simple setting I am missing?

The relevant scenes in teh model are Roof Framing and 2nd Floor Framing.

Thanks for any insight you can give me here.

Brian Gary

Trent, are we any closer to a fix for this? In the interim I’ve been using a wireframe style for my countertops, but that, being just lines instead of areas, provides less useful graphic information.

Yes, this is on our list of fixes and understand your frustration.
Sorry I cannot provide you anything solid on this and I will look to see if I can provide any other workaround.

Trent.

Has there been any update on this issue? I have the same problem when overlaying solar panels over racking.

I am having the same issues, does this mean stacking view ports in layout is no longer possible ? Isn’t that what the Nick Sonder method is based on ?

any word on a fix?

Anyone know when this will be corrected?