"Tracing" non-planar geometry in 2d

New to Sketchup / 3d and have had a pretty tough time getting my head around what feels like the “unstoppable” inference engine to do, what I think, are very common and simple tasks.

Right now, I’m recreating my residence on a site plan for a remodel. I started with all of the structures (buildings, gardens, sidewalks, etc) and have the overall model more or less how I’d like it. Groups, components, layers - it’s not perfect, but for my needs, it’s workable.

This week, I did a simple site survey with a laser level, made terrain out of contours and now am trying to get my structures and landscape, etc… all to coordinate on the Z-axis. So far, so good.

What I’m trying to do now is to “stamp” the terrain for the buildings and features. Bocce court, no problem, House, no problem.

Where I’m having a problem is with the sidewalk and driveway. The problem I have is that somehow I drew these in a non-coplanar way (I don’t understand for the life of me why you cannot easily “lock Z” in “top” view when drawing), but they are “correct” when viewed top-down relative to everything else.

Thought this would be simple. Just locked the group I wanted to re-create “on plane” and trace it, right? Wrong. When I trace it, the inference engine is grabbing the Z coordinates that I’m trying to flatten and I get a “copy” of the mistake. I’ve pulled the geometry to the side of the model, so I’m really only hitting the points of the thing I’m trying to re-create. I would have thought “lock” would have prevented the inference engine from doing its thing. I tried a “draw a co-planar rectangle first” suggestion, but either I didn’t get it, or Sketchup didn’t.

We’re talking very very simple shapes here, but they are top-down “dimensional” so I would like to preserve the work that I had and also, just want to learn how to do this for future goof-ups.

I’ve looked at a bunch of similar questions, but they generally are using jpg or pdf to trace, and I’ve also tried to find extensions that can simply flatten. Coming from a 2d / mostly Adobe world, I’m surprised that you can’t grab a group of points / edges and assign a Z value for all of them.

I’m sure I’m missing something either obvious, or just haven’t gotten my head around it correctly. Re-drawing the geometry, as it is a sidewalk between a bunch of complex geometry and terrain now, has the same inferencing problem that I can’t seem to get away from when just trying to re-trace the object.

Appreciate advice and patience from the community. Feel pretty good that I’ve gotten this far without bugging you guys, but this simple task is killing me

(apparently I can only put one image in a post, so this is the geometry I’m trying to trace from “top”), sorry I can’t upload more contextual photos

Just sayin, can only add one image to the first posts, doesn’t stop you adding many more to the next one.

By the way, too long didn’t read have to go to sleep.

You can do this in many ways, I’ll show you two:


Thanks @mihai.s!

Drape worked - I hadn’t thought to try that b/c stamp didn’t work.

What is the “center on blue” tool that you are using? I’m guessing it’s an extension, but I haven’t been able to locate it.

Thanks much

“Center on blue” it’s a plugin, part of CadFather (Max Coppoletta): JHS POWERBAR 2015 (Fixed for 2017) v2.4

You could also use:
Fredo6 FredoScale, Artisan or Vertex Tools plugins


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.