TopoShaper

Hi,
I’m trying to use TS v2.6a. It is installed and the toolbar is showing. However, when I try to use the plugin nothing happens. Both icons can be selected, but no action takes place.

I have un-installed the plugin, then re-installed it. The got the following error message;

“TopoShaper 2.6a: Error starting up pi ugin (creating menus and icons)
undefined method '‘add_item’ for nii:NiiCiass [in lib6traductor.rbe - #'add_command(): line 1391] c:jusers/mwds/appdatajroaming/sketchup/sketchup
2022/sketchup/plug ins/fredo6_! I ibfredo6/li b6core.rbe:1 072:in ‘rescue
in block in effective_load_part2’”

Any ideas?

It maybe because it’s just changed to a licensed plugin (unless you’ve already upgraded of course?)

Your “Users” folder name starts with a lowercase “u”. This ought to affect other extensions too.

Could you upgrade to LibFredo6 v12.7a, if not already done.

Then, before the Ruby error message, there should be a ace starting with ***** LibFredo6 menu****. I am interested in this trace.

??? I have not controlled or changed this. I just install the plugins. What happens after that is in the lap of the gods.

Hi Fredo, Yes I was running v12.5a. Now v12.7a; thanks. But no change in the plugin behaviour, ie. still not working.

OK. Uninstalled TS. Closed SU. Opened SU. Installed TS. Got the same error message as well as a dialog box with this text;

***************ERROR LibFredo6 Menu **************
Sketchup = 22.0.354
Platform = x64-mswin64_140
title = Generate QuadMesh Terrain (Isocontours)
Ext =
@submenu =
@menu_name = TopoShaper
@su_menu = #Sketchup::Menu:0x000001f46ca9a580


Thanks for the trace.

This is very weird, because it would mean that Sketchup fails to add a submenu to a menu. That is, the result of @su_menu.add_submenu(@menu_name) is nil with
@menu_name = TopoShaper
@su_menu = #Sketchup::Menu:0x000001f46ca9a580

I’ll need to raise this to the Extensibility team.

1 Like

TopoShaper works fine in SU2022 for me. Perhaps repairing the installation of SketchUp would take care of it? Close SketchUp, right click on the downloaded installer, select Run as administrator, select Repair. It certainly won’t hurt anything.

1 Like

Hi DaveR, Yes, I did that; no effect.

Could you try with LibFredo6 v12.8a, just released.

Hi Fredo,
Tried that but no cigar. :frowning:

Hi

Any news on the fix?

Yours sincerely,

@mwds in the future, please don’t post all the signature stuff (images, phone, address, LinkedIn profile, QR code). It is against forum rules and makes our feeds look all messy!

I have a bad Internet connection at the moment, and can’t easily check release notes. But, there were some extension related fixes in the 2022.0.1 release. If you’re not on that version it would be worth trying.

This will give you the installer:

https://www.sketchup.com/sketchup/SketchUpPro-full-exe

Hi All,
Any news on the fix? I’m using SU 2022.0.354 64bit.

I have TS v2.6a installed on Mac and Windows, and don’t see any error messages.

But, I don’t really know the plugin. Can you say some steps I can do that would then show the error message?

@Fredo6 help us Obi-Wan Kenobi…

Let’s hope the siths did not got him first….