Thumbnails for new files downloaded from 3DWarehouse

Hello all -

I’m a designer who imports a lot of 3DWarehouse models into my CAD program. I don’t use SketchUp very much; I have 2017 Make on my computer and am now using the free web versions to tweak the models when I need to.

The problem is none of the newly downloaded models have thumbnails. I realize this is probably because I have the ThumbsUp.dll for the 2017 version and it won’t display thumbnails from later versions, but I’m not sure how to fix it. The free web version doesn’t have anything to install, so I don’t have an updated version of the thumbnail bit. I’d rather not uninstall 2017 since I still find it useful.

Any thoughts??

So you are using SketchUp Make and SketchUp Free in your work. Hmmm. …

Yes. But not often enough to make it worth $300 a year. I’d be happy to pay for the ability to see thumbnails, but that seems a bit extreme…

You should read the EULA for Make and Free. Commercial use such as yours is not permitted. You should also read the EULA for the 3D Warehouse.

Sorry, I don’t mean to be dense, but I read them and I’m not sure what I’m doing that’s not permitted. I assume there’s something specific that I’m missing?

SketchUp Make and Free are not permitted for commercial use. And that is what you are doing.
Don’t know about the 3D warehouse…

I’m just using 3D Warehouse models to populate the kitchens I design, which is an authorized use.

I’ve uninstalled 2017 and installed the Viewer to try to get the ability for my Win10 machine to render the thumbnails, but it’s still not working. It’s impossible to know what model I would like to use if I can’t see it…

You can download and install the latest desktop viewer in order to view the thumbnails.


Can you shed any light at all on why Microsoft allows me to see thumbnails only for backup .skb files but not .skp files? I tried saving models to three folder locations in case it is a syncing issue: a folder synced with One Drive, a folder synced with Google Drive, and an unsynced folder. In all three locations I only see backup file thumbnails; the .skp is represented by the SU logo. Any ideas? I find this strange.

I just started using Layout, and I do see thumbnails for both the files and the backups.

OK, I have finally found the solution in this post:

Update 2 worked for me. I have downloaded Pro 2022, and all thumbnails are visible. I did bail on part of the regedit because I started to scare the bejesus out of myself, but it was still enough.

I am not a Windows specialist in peculiar. I do know that sync software has it’s own way of looking at formats, mostly based on more regular office software instead of 3D modeling based ones.
For instance, if you look at a .layout file in Google drive, it will show the contents of that zipped file ( LayOut files are actually a comprised set of Xml files and references files)
Like .layout files, since version 2021, the .skp files are zipped, too.

Maybe related.

I am not a specialist in anything tech related; I’m just confused. It’s interesting how Layout files are shown zipped in Google Drive (online) but that doesn’t give me any insight about what to do as I am seriously tech impaired. Thanks anyway.

Every time this thumbnail issue comes up, people seem to find solutions. I try them all. My hardware setup has only seen SU Pro 2021 and 2022, so there are no registry artifacts from earlier versions. I have gone through the ThumbsUp.dll registry check anyway and all entries point to Pro 2022. Never once have I seen a thumbnail for an skp.

I have posted a screenshot of what I see in my folders. Maybe somebody out there knows how I can trick Microsoft into letting me see thumbnails instead of those blue SU Logos.

Did you try downloading & using the two free programs listed below? They are what worked for me. Since you did have two versions of SU, maybe there are still some registry conflicts?? (I’m not techie either, so that’s just a wild guess.)

Thing is, I never had SketchUp installed on this hardware prior to Pro 2021. I never saw thumbnails from the beginning, so leftover registry artifacts from older versions were not an issue. I uninstalled 2021 using Windows uninstaller thinking I may not have installed SU ‘correctly,’ but that did nothing.

I let the issue go until 2022 came out, then I installed the new version as administrator and checked the registry to make sure the ThumbsUp.dll entries pointed to 2022. Still no thumbnails.

I may go through this process one last time using the free Revo and CCleaner to get rid of every last trace of both programs when I have an hour or so to kill setting my workspace up all over again.

Hint to SketchUp programmers, when I use the Windows uninstaller, how about you remove all of your files from my computer? I know programmers like to leave little breadcrumbs around on purpose, but it does seem to cause some problems.

I’d recommend trying it. It literally only took me about 10-15 minutes to do the whole thing.

Good luck; I agree that this is just plain stupid to have to deal with!