Those kinds of things

this is the kind of bug / glitch ? that makes me lose so much time while working…

Can someone explain me why, if we offset the outline like in this capture, it messes up the inner bounderies that were just fine before ?

There’s no way to get it back once the offset is done. intersecting won’t do anything. Redrawing won’t do anything. I tried to spot small gaps with edge tools, none flattened everything again, no improvement.

Here’s the file if you want to try and enlighten me ! (it was done in sketchup 2021 but I saved it as 2017 so most people can open it)

I don’t want a solution, I manage to get it right.(but it makes me lose time !) Just an answer to why sketchup acts like this !

test.skp (87.2 KB)

It’s due to the internal lines… if you clean the object everything is fine

Otherwise, we would normally:

  1. ‘Select’ the outer frame/object then
  2. ‘Group’ the object then
  3. ‘Edit the Group’ then
  4. ‘Offset’ the edge then
  5. ‘Explode’…
1 Like

I would agree that it is a special-case bug. The logic for offset seems to be especially fragile. There have been bugs in previous versions, especially at sharp corners. This is the first I’ve seen that involved interior edges not part of the outer loop, but the contrasting weight of the edges suggests some are profiles while others are not. That may be confusing the algorithm.

1 Like

thank you for your answers.
@BiMUp those lines are here for a reason as there are different pieces of metal with different thicknesses, I can’t just “clean them up”
If I said I did not want a solution is because I always find a work around to get what I want or need to get. It just is really annoying to have such unexpected behaviours.
I mostly use sketchup for competitions. I’m not able to tell my client “you’ll have it next friday”, or “It took longer than expected”.
We have really short deadlines to produce things and having to add steps like the ones you gave me (I’m not blaming you at all, and thank you for the help you are trying to give !) is just painful.

The piece is just one part of a larger model that i’ve done this afternoon :

If I have to find workarounds for every little part of it, it’s a big amount of time.

I love Sketchup, especially for how fast it allows me to build things up. I’m simply pointing out the fact that it can still be improved,
And if I was a programmer, I’d definitely see this as an unexpected behavior and would try to fix it.


What happens if you select just the outer edges instead of the face and offset them?

Exactly the same. It is way too long anyway !

That is a stubborn one, I suspect it related to the bug I’ve been trying to get them to fix for years. I call it the gothic bug as it always fails on the ‘triangle’ created by a gothic arch.

Gothic bug


oh yeah I heard about that one. But i’m not sure it is related ! If you check offset tool behaviour for your example in several versions of sketchup, it is acting very differently from early versions till 2016, giving a strange result that we were used to at the time. In 2017 it works surprisingly well, the offset tool simply stops showing the preview once it gets too small or messy. and then gets messy again with 2018 which acts just like in your gif.

My issue occurs no matter what version you are using and involves geometry we are not directly dealing with, leading to an obscur conversion of edges into profiles, just like if sketchup was not able to discern closed areas anymore.

1 Like

@paul.millet sorry that I couldn’t help in a better way…
I can see that you are not looking for some workaround but, at the back of your problem other SU Users can learn the techniques to achieve required modelling objective.

Paul, I’m sure you know that but, for other SU Users, the other option would be to:

  • ‘Group’ the face which needs the ‘Offset’
  • ‘Open’ the ‘Group’ and then do the ‘Offset’ then
  • ‘Close’ the ‘Group’ then
  • ‘Explode’ the ‘Group’