Text in Hebrew appears from end to begining


#1

Hi,

In Layout , when I write a text in Hebrew , I had to write the text from the end of the text to the beginning ! If I do not do this , the text in PDF text appears in the end to the beginning !
How can I control it and fix it , so I can write as usual and did not start from the end ?
Almost the only font that is possible to write him Layout called Arial . If I write a different font , then in simple PDF text will not appear .

Thanks
Elhai


#2

no one can help me?..


#3

did you look at the [Hebrew Sketchup Blog][1]?

otherwise @Anssi knows a thing or two about using different PDF engines that may help…
john
[1]: http://sketchup-hebrew.blogspot.co.il


#4

The text direction problem is all Hebrew to me (I mean no offense - it is a saying here in Finland I couldn’t resist using). It might stem from a bug in LayOut, or your system settings (is your operating system default language Hebrew?)

If you use some other Hebrew font than Arial, will it be invisible in your own computer or only some other person’s system? Are you using Adobe Reader to view your PDF files? I would guess that the LayOut exporter doesn’t embed your fonts in the PDF document, and the Helvetica font that Adobe uses internally to substitute for non-embedded fonts doesn’t have the Hebrew character set, but I think that it ought to be able to use also the original font if it is installed in your system.

There are no settings in LayOut involving PDF font embedding, so the only option that comes to mind is to use a PDF printer instead of the built-in exporter. PDF printers can be configured either to always embed the fonts used, or to print the file as a high-resolution raster image. Both the options should ensure that the file can be viewed even if its recipient doesn’t have the original font installed in his/her system.

Just guesses. Posting a LO file and a PDF displaying this problem might help troubleshooting.

Anssi