SVG outline plugin and Make 2016 on Mac


#1

Hello. It seems as though the SVG outline plugin doesn’t work on the Mac version of Sketchup Make 2016. I have the latest Mac OS X. When I click the save button nothing happens.

It does work on a Windows 8 laptop, but unfortunately right now I dropped that laptop and cracked the screen so my Macbook is the only option. Another person also verify this was not happening for him also.

Anyone have any solutions? Thanks.


#2

I would guess that you might get almost similar results by printing to PDF with the Vector Printing option enabled, and then using one of the zillion available free converters or a graphics application (Inkscape is a free one) to convert the file.

Anssi


#3

the ‘mac’ port of this plugin has been discussed in the developer forum over the past few days…
PLUGIN link is here

there are some details on how to install at the dev topic…

john


#4

John, which developer forum are you referring to? I couldn’t find it…

Also the 1.2 version I found at the link you provided still doesn’t work for me - it says it has exported, but nothing appears. I believe that there are still multiple errors in the webdialog’s html that cause javascript to throw (silent) errors and fail. I’m working on sorting them out using the WebKit inspector (I got the old version working that way…). There is also a confirmation dialog that “underpops” the main view when you save. You can’t see it on Mac unless you move the view aside!


#5

I have a modified version that now works on Mac. Turns out it only needed minor fixes. However, the discourse software won’t let me upload it here! If anyone can’t get the official version to work and would like my patches, PM me your email and I’ll send the files to you.


#6

Steve I posted a .rbz of it here last night, i.e. no discourse issues…

the thread got moved from Technical (bug) to HERE

email your fix and I’ll see if I can repost yours…

john


#7

I emailed the two files to you.

It’s strange. When I tried to upload the rb and htm here, I got a popup listing a bunch of file extensions it said were prohibited.


#8

I just realised it’s the ‘other’ SVG plugin I tweaked last night…

john


#9

I wrapped it as a rbz…


#10

Would you mind sending the instructions and patches to me?

Jeffkalive@gmail.com

Thanks!


#11

i’ve been away from my computer for a few days, coming home tomorrow. I’ll see what I can dig up then.


#12

The easiest is just the .rbz file. For SketchUp 2016, install using Preferences->Extensions->Install Extension. I have not tested this on SketchUp 2017 as I don’t use it myself, though off hand I don’t see a reason why it wouldn’t work.

flightsofIdeas.rbz (38.4 KB)


#13

Hi,
I’ve tried that endlessly, no luck. I just can’t seem to get the extension to work for me.

Thanks for the help.

Jeff


#14

Can you describe in more detail what you mean by “get the extension to work”?


#15

HI Steve,
I’ve installed the extension in the latest version of Sketchup(non-pro
version) and it won’t save/convert the file/drawing I’m trying to
save/convert. I click on the save button and nothing happens. I’ve
uninstalled and reinstalled a couple of times, restarted the computer a
bunch of times and no joy.

I agree, extensions should, and are, be super easy. I just can’t get this
one to work properly.

Thanks,
Jeff


#16

Have you tried opening the Ruby Console window before running the extension? Messages written there would help diagnose the problem.


#17

Hi Steve,
I tried using the Ruby console to see what, if anything, is happening when
I’m trying to use SVG. Nothing pops up on the console, it’s like SVG opens,
looks like it will work, but nothing happens. Nothing generated on the
console. It just seems to be dead.

Thanks,
Jeff


#18

Sounds like an issue with the dialog sending info back to Ruby. I’m not at my computer now. I’ll see what I can figure out tonight.


#19

I’m having the same issue as above where I click “save” and nothing happens, the button is just clicked and un-clicked. I’ve read the replies, still not sure what the fix is. Any idea how to resolve? I tried the same version as SirPoonga above. Had trouble installing John_drivenupthewall’s linked version.


#20

Recently on Sketchucation someone posted about having difficulty getting SVG files. I suggested adding .svg to the file name which worked for them. Evidently the exporter doesn’t automatically append the extension. Maybe the same issue here?