Surfaces created without lines

Why does SketchUp sometimes create sufaces without lines (or fragmented)?

Probably because you use the Layers/Tags in a way not recommended, especially for beginners. Turn on the layers, and all raw geometry (lines, faces) assign Layer0/Unttagged.
Or maybe you have hidden lines - turn on View > Hidden geometry.

DO NOT work like this!

Thanks for the reply mihai. Sorry for the misleading question. I was in a hurry and forgot to mention that it was an imported dwg file. But I did find out what was the problem! The dwg file had lines on an elevation I missed so I didn’t flatten it. Dumb mistake. Have a great day!