Sun & Shadows With Dome or Backdrop

I’ve done some extensive searching on Google and I can’t find any relevant discussion about this. I know that, typically, if I can think of a solution to a problem, some person (likely much smarter than myself) has already implemented it in some way.

My problem is this:

When we present a polished version of our model to a client, we utilize the sunlight feature and shadows. We’ve also started to implement backdrops and in some cases, domes, in order to add that extra bit of realism to a presentation. But the problem we’re noticing is that when you combine those with sunlight/shadows, your backdrops will cast a shadow, and your domes will flat out block the sunlight totally, throwing a shadow over the entire model.

I just have a sneaking suspicion that there’s a workaround for this problem, but I don’t know what it is. I’ve looked through plugins and I’ve searched for built-in features that might solve this problem, but I haven’t been able to find anything yet. Can anyone help me with this? My intuition tells me that there should be a way to tell SketchUp to allow sunlight to pass through specific faces, but I’m not sure how to go about doing that.

And if there isn’t already a plugin for this, I think it would be a highly useful plugin for some brilliant coder to create.

Can you provide a (the) model with your problem, to put side by side with your question?
And please, in future help requests less rant to avoid having to read to all the text.
To ensure better answers.

select your dome: Entity info window: Uncheck cast shadow and uncheck receive shadows.

1 Like

So, unchecking both of those boxes does eliminate the shadows, but I noticed that the faces themselves are still darkened. Did I do something wrong?

Glad to be of help. Without seeing your model it’s guesswork at best to diagnose what you are seeing. Perhaps the “darkness” is due to sktechups default shading. Sketchup constantly changes the shading of all faces as you orbit around depending on the angle that is presented to you, it helps your model appear 3d to you as you are looking at a 2d screen. But, sometimes surfaces at a steep angle appear darker. Try Window>Shadows> check use sun for shading, that turns the shading function off, see if that makes a difference.

If you have stills(scenes) you can also attach a style with a watermark to it. Watermarks (jpg or png) can blend with the model on the background or create masks

Example: Sky_Dome_Example.skp (1.2 MB)


You’ll find rendering the model yields better lighting and a more realistic sky.
SketchUp > Kerkythea

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.