Suddenly can't save file to current version (SketchUpPro 2022)

After saving my work several times (File>Save) I got a message saying “Sketchup is unable to save your model. It is recommended that you attempt to save your model to SketchUp Version 2020 or earlier to prevent any loss of data. If the problem persists, please contact Customer Support at https://help.sketchup.com/contact.

I tried a few more times saving like I’ve always done in the past and still got the same message so I did save my work as a 2020 file which apparently worked but never had to to this till today…confused! I have to confess too that I’m a little scared to quit the program for fear of it being damaged in some way :fearful:

That can happen if there is something corrupt in the model, that SketchUp cannot fix. We have made changes to fix more things, and the next update may handle the problem better. But, could you send the file to me, so I can make sure its problem has been taken care of?

Thank you for your speedy reply…I’ve been working on a microGrow build and imported a cannabis plant from the 3D warehouse “Marijuana Plant by Hemisha B.” so I deleted it and purged both my in model components and materials after reading your message because that was the only thing I imported into my model today and Voila! I can save again!! SO happy, thank you @colin :hugs:

Thank you for the update. I will get Marijuana Plant by Hemisha B checked out, to see if it has problems.

Thanks again @colin, I removed it from my 3D warehouse collections just as a precaution.