Corrupt file. Can not save anymore. Please help


My file is corrupt and I can no longer save it. I have tried to save it in older versions, but that did not work. I also tried exporting the content into a new file. Even bit by bit, and it still does not work? Does anyone have tips for what I can do here?

I can upload the file if needed.

Hope to hear from you, and all the best.

Flying Potato.

Have you looked to see if the backup file is viable? There should be one with a ~ in its name.

Hi Dave,

There are backups. The most recent one, has the same problem some how. Tried to save it under a new name and it did not work either. Very strange.


Are you saving locally or to the cloud?

I am saving locally.

Does the file name have some strange characters? Have you tried purging unused stuff from the file? Did you use components from the 3D Warehouse? If so, have you tried examining them individually to see if there’s any potential problems? Did you use any unusual textures? Have you tried removing textures to see if that changes anything?

Unfortunately it seems to be a very rare thing when a corrupted file can be recovered so if you still have it open on your computer,looking for suspect components and/or materials is probably your best bet.

If you start a new model and save it, does it save? If it does, can you Copy and Paste in Place chunks of the old file, and then save the new file again?

Hey Dave. Thanks for following up. There are no strange characters. I have tried purging, and fixing - still not working.

It does include warehouse components, but even without them, it does not save. No unsual textures, but will try without.

Thanks again for good advice.

Hello Colin,

I tried that, but it did not work unfortunately. It is rather frustrating.

Which part failed, could you do the copy part, but not the paste in place? Or both and not the save?

Also, were you doing Paste in Place and not Paste?

I could copy, and paste in place, but after that, it will not save.

I usually paste in place. And did so now, yes.

I can put it on a google drive and dm the link to you if you want to check?

What error messages do you see on screen, if any?

Can you copy your objects and paste them into a Layout file and save that?

The error is: Failed to save file.

I can not export to layout because, ironically, you have to save the file first to do so…

You don’t have to save in SketchUp first if you just copy some objects and paste them in a new Layout document.

ok, great. I’ll give it a go. Thanks, McGordon.

That only copies views of the model into LayOut. It doesn’t copy the actual objects.

It worked for me. They come into Layout as SketchUp models. If you right-click on them and “Open with SketchUp” you’ll get the objects that you never actually saved in SketchUp.

I gave your file a shot. It opened and saved just fine for me. I wonder if it’s just a case of not enough space on your drive.

I did run CleanUp3 on it and knocked about 15% off the file size. You might give that a try.

Screenshot - 5_26_2020 , 3_21_17 PM

Thanks for checking, and awesome that you reduced the size. Can you put the model you saved back in the gdrive folder? I have 77gb available on the disk, so it can not be that.

It’s uploading now. I’ll send you a link when it is finished.