SU Pro 2019 crashed, file format now not recognised, no AutoSaves

I’m trying out the 2019 Pro 30 day trial for an important project, everything was feeling good and was running fine and I’d be having a good day or so using it, but I just experienced my first program crash when moving a rotated .dwg imported into the project that I’d done quite a bit of work on.

Now when I restart SU 2019 Pro, SU says “Unexpected file format”. I have just lost 5 hours work (and I had regularly saved my file!), plus losing another couple of hours trying to find solutions and reading these forums.

I’ve checked for the promised AutoSaves, for which I’ve checked that it’s active (every 5 mins) and it should be saving to my default “My Documents” on drive D, but it’s not. As a further test of that I tried creating a new AutoSave location on my SSD C drive, and I have tested this location with a saved open file (with changes added now and again) and nothing ever saves in it.

The suggested place to enter this location in preferences is in Files>Models, which seems odd and I wonder why there isn’t a more obvious AutoSave location to specify under General (in Prefs), by the actual AutoSave button?

To make matters more annoying, I have always practised saving out my own backup versions, e.g. myfile-v1a, myfile-v1b, etc., and a short while before I started doing the rotations that caused the crash, I’d saved out a myfile-v1c, this usually saves my day if anything should go wrong, but it’s not much good when the program can corrupt files when it crashes!!!

I’ve had to revert to my v1b file and have lost my work after that point.

I have now lost trust in SketchUp’s ability to be reliable. If a crash can corrupt a file and AutoSave can totally fail, it’s hard to trust SU at all. I shall just have to do loads of manual saves and re-saves all the time, but I fear that I may get files that cannot be opened, something I’ve rarely ever seen in decades of creative computing.

Otherwise my system runs flawlessly, I run loads of software including all Adobe stuff all the time so it’s not my flaky system.

Is there a file repair utility anywhere? (There needs to be one!) I can’t find one anywhere and does anyone have any clues why AutoSave is not working at all?

Auto-saved files are not saved in the same directory as the original SketchUp model.

On Windows you will find them here:

Thanks for the information on the true location of the backup files. Unfortunately this does not seem to be listed anywhere on the forums, preferences or help files, but the following is listed just about everywhere:

(ref: Where Are Autosave Files?)

In the folder you mention, despite SU only crashing the once, and no known other issues, I seem to have several files in there:

The v1k one is a later one so I have no idea why that’s in there (I’m now on v1w), and the ones before v1c had no issues.

Anyhow, I tried opening both of the v1c ones with SU but SU just complains with “Unexpected file format”, I tried changing the file suffix to .skp and same result. Same result with all .tmp ones. Only the ones with .skp on the end open properly, which of course also show as recoverable when SU is opened. What I don’t understand is that neither v1k or tutorial had any issues, my computer was fine and I didn’t experience any issues at all whilst using those files, so I have no idea why they are marked as recoverable.

When I change the .tmp to the .skp extension, when I hover over the file I can see the thumbnail of the file, they just don’t open.

Not a very useful AutoSave backup system is it. The v1c ones are when SU crashed and didn’t help me at all despite SU having enough time to save the AutoSave file several times.

How robust is the whole file saving in SU? Are corrupt files frequent and is it normal for loads of files build up in the temp folder as well as experiencing otherwise okay files showing in there as recoverable?

You are referencing information that is 4 years old. The location has changed since then.

Could you post a screenshot of your File Location preferences? Feel free to obfuscate the user name, but I’d like to see the paths if possible. Also, was the SketchUp application installed on the C: drive?

I realise that the info is old, but newer information is not available. It would be handy if it was mentioned in the preferences, perhaps with a place to optionally specify a preferred location. In the absence of anything to the contrary, one can only assume the MyDocuments location is still valid.

Any thoughts on why I can’t access the .tmp files or why a .skp was not saved that I could access? Maybe I was just unlucky and had file corruption - worrying though on my first project!

Thanks for your help/advice :slight_smile:

Details requested as per prefs export:
[File Locations]
Classifications=C:\Users\XXX\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Classifications
Components=C:\Users\XXX\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Components
Materials=C:\Users\XXX\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Materials
Styles=C:\Users\XXX\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Styles
ComponentBrowser=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\Components
ComponentBrowser1=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\Components\Dynamic Components Training
ComponentBrowser2=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\Components
MaterialsBrowser=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\SketchUp\Materials
MaterialsBrowser2=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\SketchUp\Materials
StylesBrowser=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\SketchUp\Styles
StylesBrowser2=C:\ProgramData\SketchUp\SketchUp 2019\SketchUp\SketchUp\Styles\

Default install location on 64bit Win7 Ultimate on C:\ in ProgramFiles. MyDocuments was moved to drive D:\ years ago.

Thanks, much obliged. If possible, could you email me a couple of your corrupted files? My email is markc/at/sketchup/dot/com

Thanks, email done - the email totalled 25MB - let me know if you don’t receive it.

Received, and forwarding them to development.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.