SU 2017 opening wrong version (2016) in widows 7 pro 64 bit


#1

For some time when attempting to click and open a skp file I get a error that states I need version 2017 but I have version 2016 when I actually have version 2017.
If I save file then I can open OK with version 2017. I have tried setting the correct version in the control panel but, it will not recognize that change and SU still opens in 2016.
My search ( Window 7 forum: https://answers.microsoft.com/en-us/windows/forum/windows_7-files/problems-with-file-association-in-windows-7-64-bit/8a84fcec-22df-4942-8e35-d98dbe96e327) on the net indicates this is symptom of improper program registration. Following their suggestion: "In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name. Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and re-associate the file type as you normally would."
In that link I find Google as link reference and not the new file tree.
Before I muck with the registery I wanted to find if others had / have the same issue and solution if any??


#2

I think this has been reported in the past.


In my registry, I do not have a “command” key under “shell\open”, at "HKEY_CLASSES_ROOT\Applications\SketchUp\"
Just an attribute “FriendlyAppName” whose value is the application name, ie: “SketchUp 201x``”

The pointer to the executable path is actually at:
"HKEY_CLASSES_ROOT\SketchUp.Document\shell\open\command"


Did you reinstall 2016 after having installed 2017 (even just for a quick test) ?

Have you tried re-running the 2017 installer (right-click “Run as administrator”) and choosing “Repair” ?


#3

Thanks for input:
No su2017 after 2016; ran as admin
Tried repair for Su2017 but no joy, got strange error message. Not quote but, could not be done because SU2017 on network which it is not. My router is not set up as Wi-Fi so do not where that is coming from.
Have been delaying trying install because I use the make version and some what concerned when that is done will run into license issue.
I’ll delay mucking with regeistry until get sorted out. I’am lucky run same version of windows -7 sp1 as you.
Have dentist visit so off to that.
IMHO W7 is really bad on how they set file association.

Thanks again: slight_smile:


#4

XP was no better. I had similar problems at work where with some applications the association with an older version persisted, but it was rather expected with all the restrictions the IT dept has invented.

Anssi


#5

I was trying the repair from the control panel add remove programs. Luckily I still have the installer in the downloads folder. I tried from there and it appears to let me select the repair option but will have to run some test.
Thanks for Inputs!!


#6

Trouble shoot to date:

  1. Using Orginal installer in the download folder did a repair of S2017 file as default program to open;
  2. If I use the normal windows control panel ( programs and features) and click the repair button it starts to install and what is really weird: Program Install is 22a7b.msi ; verified publisher is Trimble Navigation and file orgin is hard drive on computer.
  3. If I repeat the step get same result but file name is now 43b951.msi and I cannot find either of those files on the PC. I have not checked temp folder yet
  4. Used regedit to check registry does not give the same result as you have.
  5. I can now set SU2017 as a default to open but it would seem I should see the same registry as you do unless the free version gets differnt results;
  6. Note I do not see path you do and the open path is funny. In the open Brach The FriendlyApp with data of SU2017 for it now shows;
    In the > .Document branch this is what is showing

#7

The top image (HKCR\Applications\SketchUp.exe\shell\open\command)
shows an old Google SketchUp 8 (or previous) path.
It may just be left over from an old install.

The names are randomly generated, and they should reside in “C:\WINDOWS\Installer


#8

Thank You Dan
I Never touch the registry and starting to think there are some issues some place. When I remove a program I use the supposedly correct way ie control panel add remove programs.


#9

Dan could not find the installer link but it does have many amd installs.
I did open and elevated command prompt that is not user specific and ran Windows SFC which scans the integrity of protected windows files and replaces incorrect / corrupted; changed / modified or damage to correct version.
That run did not report any issues.
However, I previously noted when SU transitions from PRO to free the layout and style builder still show in the control panel add and remove programs. In the past I then deleted those via the control panel. However, I do not think all remnants of those where removed. As a side I recently concluded the my SU version is running in a 32 bit mode even though I have W7 64 bit and down loaded the 64 version of SU. I base that on the fact the measurement box was not reporting enough digits , 7 which is the 32 Float accuracy.
I have now done another W7 64 bit repair and quick check shows meas. box now reporting more digits.
I am stiill abt.1/2 thinking with all the changes Trimble is going through there some issues with registry
they are over looking especially with free users.


#10

Comments about the float 64 digits was factually in correct. The meas. box now showing more digits , not ~ 15 for 64 float but several more than the 32 bit version. I did remove the extraneous command for SU 8 as you pointed out, the repair and this makes the registry same as your now. SU2017 now opens ok but there are still some remnants of layout and style builder in the registry but this time not going to delete.
Thanks Again with the help!!