Styles open window has funny thumbnails with question mark and small green watch

styles
thumbnails
hardware

#1

DURING A PROJECT PRESENTATION THERE WAS A POWER CUT, I HAD TO RE-START THE SYSTEM AND SKETCHUP,
FROM THIS MOMENT ON MY COMPUTER (POWER BOOK PRO 2008) AND SKETCHUP DID NOT ANYMORE BEHAVE AS BEFORE. WHEN I WENT NOW THROUGH ALL MY FILES I SAW THE THUMBNAILS IN STYLES, I ADDED NEW STYLES TO MY PROJECT AND THAN ALL THE STYLES LOOK THE SAME. PLEASE GET ME SOME HELP.
SORRY FOR MY ENGLISH I AM AUSTRIAN :sweat_smile:Screen Shot 2015-10-10 at 11.39.32.pdf (53.6 KB)


#2

That’s a shame, did Caps Lock also get jammed on or are you yelling at us?

A corrupt Preference List [.plist file] can cause this ‘missing Styles folder’ issue…

are you ok with using Terminal.app or the ‘Ruby Console’ inside SU?

Please use Uppercase sparingly…

john


#3

Thanks for reply
sorry john about caps lock, since I finished my engineering and architectural study it was 1964 I use uppercase letters in hand writing and in typing.
I am not very much ok with Terminal.app simple command i may be able to add, no experience with ruby console at all.
hans


#4

Ok, if you open ‘Window’ >> ‘Ruby Console’ in the SU menubar…

a new Window with two fields will open…
Click in the bottom field, allowing you to enter text…
copy/Paste this following line and hit enter/return…

Sketchup.find_support_file("Resources")

it should return this message…

> Sketchup.find_support_file("Resources")
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Resources

does it?

john


#5

Thanks for replying, I am at the moment out of my office will execute as soon as I am back.
Thanks, Hans

Von meinem iPhone gesendet


#6

yes john, it returns as you mentioned


#7

In that case, I try a ‘Safe Mode’ restart of the computer first…

Basically, Apple [in the top corner] >> Restart >> wait for start >> hold Shift till chime… [check the web for more detailed Instructions]…

this will fix any system wide permissions issues…

then, do Shut Down>> Turn Power Off >> wait a miniute >> On >> Start to see if SU Styles come back…

Report back…

john


#8

John, sorry no improvement, I think there is a problem with my hardware too.I can only start the computer in Save Mode if i don’t press shift the start up gets stack, only when I restart and press shift the computer is booting. After the Save Mode start, I checked SU no change on Styles.
hans


#9

ok step two is to rename the SU plist, delete the cache so SU can create a clean version and to see if the new one fixes things…

In 10.8 and later, the CFPreferences agent process (cfprefsd) will cache information from these files and asynchronously write to them. This means that directly modifying plist files is unlikely to have the expected results (new settings will not necessarily be read, and may even be overwritten). You should use the NSUserDefaults or CFPreferences APIs, or the defaults(1) command, to interact with the preferences system.

For now we just rename the file, so back in Ruby Console copy/paste and enter this

plist = File.expand_path("~/Library/Preferences/com.sketchup.SketchUp.20#{Sketchup.version.to_i}")
copy_plist = plist  + " copy.plist"
File.rename(plist  + ".plist", copy_plist)
%x( killall cfprefsd )

Restart SU not the mac…

any joy?
john


#10

JOHN,
thanks it worked out so far, I got after starting SU the Simple Tamplate -Feet and Inches green foreground and blue sky and the friendly man in the middle.
When I open Styles i still see the question mark but without green watch in the corner. when i open default Styles 5 of them have still the green watch in the corner.
hans
JOHN


#11

seems like your still missing some Styles…
try entering in ‘RC’

Sketchup.find_support_file("Styles")

what does that return?
this is how it should work…

BTW: the green clock means it’s a ‘fast’ style that won’t slow SU down…
john


#12

John, I am sorry I can’t continue now, I am on the run to catch a flight to Europe (from Saudi Arabia) will try what you told me as soon as I am back. Thanks for all.
HANS

Von meinem iPad gesendet


#13

I had this same problem. The solution was the image used as a watermark was moved for its orriginal folder and in turn, skechup was confused and would not show any of the styles as normal. The key is I had in

Windows–Preference—Files—Watermark Images_

Location set to my pictures folder. This was great until I deleted my sky image. Once I put that image back in that location (or changed the Watermark Image file location to the correct location of wherever the image was saved) the Style icon look perfect.

As a side note, when i opened sketchup and the style icon had the question mark on it, I could load any number of other styes and when I looked at the styles inside the model itself, they all had the question mark on them. If i exported them to another file, they still had a question mark on them. Again, once that watermark image file was in the right location, (or the location was changed) all the styles worked out perfectly.

I bet when the computer crashed the image file was corrupted or deleted from a temporary directory if you downloaded from an email into the temp file location.

Best Regards,


#14

I want to add to my last comment. The

Watermark Images–

preference settings were incorrect causing the styles to show up incorrectly, a.k.a. with a question mark on them.

In addition to that, the

Sketchup Styles Template.skp

file was also located in the incorrect directory and once it was placed in the proper folder,

C:\Program Files\SketchUp\SketchUp 2016\Styles

all of the styles showed up correctly.


#15

You need to press Caps Look. It’s positioned just above your left Shift key.


#16

How did you manage to get these things in the wrong place?


#17

My office designs hundreds of buildings a year and we have gone through the entire folder structure and removed anything that is not used and recreated all of the libraries and menus. While customizing everything, apparently someone thought we didn’t need the template file in the styles folder.

Everyday we learn something new…