STL Import Squaring Up model & non-vertical faces

sketchup
stl
import
modeling

#1

I’m helping someone turn a model that was built for 3D printing into an interactive rendering. The file came as an STL and I’ve started working on adding details (i.e. adding windows) and changing the features from being building around printability to being real-world representative (i.e. the siding in the printed model was made up of indents in the side of the structure, where as in the real world it’s a series of slightly diagonal materials).

The problem I’m running into is that the model isn’t really registering as being squared up. For example, when I try to apply a clapboard siding via the floor generator tool, is says it can only be applied to vertical surfaces. When I create a new rectangle based on the dimensions of the face, it works fine.

I guess my issue is that there seems to be all these microscopic faces that aren’t adding up with each other.

When I first import the STL the model looks like this:

Any suggestions on how to fix this?

I’m attaching the original stl model at this link:
https://drive.google.com/open?id=108ZUzo1VC3xkr8fTkpeUgt8uqglP4Nby

Here’s the skp version I’ve been working on: https://drive.google.com/file/d/1RVz7fNX-z9qAcd4xQg2hxDIadTFlhV2j/view?usp=sharing

Here’s a photo of the structure in real life to get a sense of what I’m trying to recreate:


#2

As the model is quite simple, I would use the stl as a guide and draw it again, might be quicker than working with that mesh trying to get it up to scratch.


#3

Yeah, I’m thinking you’re right. I was sort of starting to do that in another file just in case, but wanted to check just in case. I tried the suggestions from “this post” and it seemed to help, but it didn’t solve the problem. I feel like this is one of those time where if the problem isn’t 100% solved, then it will come back to later on and take way way way more time to fix than if I just rebuilt from scratch


#4

Yep and it’s also going to take longer to cut and edit the mesh as it’s got a lot of un-needed polygons because of the import.


#5

When importing, did you check the “Merge coplanar faces” box in the Import options?
image


#6

I actually just tried that and the result looks really good, not that much triangulation at all. Its not perfect but better than the first image of STL import.


#7

Yeah, I did. It got rid of most of the problem, but not all of them. I think Liam887 might be right that the best strategy is just to redraw the model from scratch.


#8

My issue is that even though some of the things look fine, many of the faces are still not registering as being vertical (i.e. there’s hidden triangles & stuff)


#9

The import option “merge planar faces” takes out any unneeded lines of faces that are planar, hence the much cleaner import. The problem you have remaining is that the diagonal crossed faces are not “planar” in the original .STL so the lines between them have remained in order to preserve the face.

I just did the import again and changed the edge style to “colour by axis” which colours any edges on the red/green/blue axis by the corresponding colour. It gives a quick indication to show where things have led astray. As you can see from the image the result isn’t a total disaster but I’ve arrowed a few lines that should be coloured but are not. It’s mainly the base, the door has some issue too.

Personally I’d rather attempt to fix or redraw just the base than start from scratch when most of it is ok.


#10

Okay, this really isn’t working out. I even remade the model from scratch and I’m still running into the same problem. I just trying to intersect my windows with my wall to get rough opening cut outs and these diagonal lines showed up. What am I doing wrong?

Link to current model: https://drive.google.com/file/d/1PKQ7reKny2QOAY4XNlbwQdNb9xJEIYKs/view?usp=sharing


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.