STL file modification - add solid to object - problem with printing

sketchup
stl
solid
solidinspector

#1

Hello everyone.

I am new to Sketchup and 3D printing.
I am currently using the pro trial version.
I need to modify a STL file that I downloaded from Thingiverse.

I tried to add some kind of “cube” to the object but when I try to print it the cube is not recognised as a solid.
After some google searches and forum reading I downloaded ThomThom’s Solid Inspector 2 and tried to solve the issue.

The tool was able to fix some “stray edges” problems but it keeps telling me “Surface Borders” error and “Nested Border” errors - Unfortunately I don’t know how to fix them.

Can anybody help me with that?

File:remote-cover-with-speed-limiter.skp (2.6 MB)

Cheers Dominik


#2

Working from imported STLs is not a great idea. The STL file is triangulated which creates problems when you get into SketchUp, especially at the size you are working at. There are all sorts of holes that need to be fixed. That’s what “surface borders” usually implies. There are some in the text on the inside.

If you soften the edges, it’ll make it much easier to see all the problems.

As for your little cube, it is placed over the group but it is outside of the group container. The cube is loose geometry and it’s faces are reversed so it wouldn’t print anyway.

If you really must use that thing from the STL, you have a lot of work ahead of you to repair it before you consider adding anything to it. You might be wiser to start from scratch instead.


#3

first, use a different template, the 3d one is pointless…

try product resign millimetres…

then, re-import the stl using meters as the import unit…

john


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.