STL fails to slice properly

My designs look fine in SketchUp and in the Simplify3D slicer preview, but not in the process preview and not when printed. I get extra threads running over the print, and often extra surfaces on top of the finished object. Very simple objects, and ones with all straight lines work fine. When there are curves, I usually get a mess. Sometimes when I change the order of construction, ending up with exactly the same design, the print will work, but I waste a lot of time redrawing them hoping for a print. slic3R also fails to print, so I think the problem is in the exported STL file. I can make the same object with InventorPro and it will print correctly.

Upload a model that has these problems so we have don’t have to guess.

1 Like

The file is a HO scale (model railroad) model of a signal head. The lamp covers were made by pushing down the center of a cylinder and then cutting off part with a plane. Then the covers were copied into holes in the back piece. The file looks good to me and when loaded into simplify3d slicer, but the animation in the slicer shows the covers missing completely and several extraneous lines.

SignalHeadTest.skp (1.3 MB)

Have a look at these files, do they work for you?
SignalHeadTestBox.stl (29.0 KB)
SignalHeadTestBox.skp (60.4 KB)

The object is not a manifold solid.
Make it into a group and look at its Entity Info - it doesn’t say ‘Solid’ in the header.
It has internal partition faces.

If you delete those surfaces it then is a solid and it should then export to STL properly…

1 Like

Thanks for your really speedy replies. I am unable to load the skp file because I have the 2017 Make version and have been reluctant to buy Pro because I am having trouble with this version. I did load your stl file into simplify3d and although it says the model is manifold, it still fails when I run the preview animation. The covers are missing and there are extraneous lines as before. I then used the section plane to see the inside surfaces of my skp file, removed the inside surfces, grouped the object and exported STL again. The animation still shows the covers missing.

There must be something I am missing. Even when I get a model that SketchUp reports to be solid, and which the slicer reports to be manifold with no errors, I still do not always get a good print. Sometimes there are missing parts. Sometimes there are extra lines or surfaces that are not shown in the skp file. Sometimes after a trivial change, or even just selecting a part to print and exporting it, a print that failed before starts to work, or a part that worked before fails. Sometimes my models work the first time and every time. Attached is a skp file for the signal head that is manifold, reported solid, but does not print the lamp covers.
SignalHeadTest2.skp (1.3 MB)

Its interesting that the lamp covers do not show in Slic3r in the preview panel. Although, if I scale the part up by just 5 per cent or more they then appear.
I’m no 3d printer boffin, but is the part just too small or is it filament size or something? Just a few thoughts.

The part is small. But I also have had trouble with larger parts. I noticed something today in the forum about drawing in a larger scale and then reducing the size before printing, but I have not tried it yet, and I don’t see why that should matter when the StL file is written. I have scaled this model larger and then tried printing it at the larger size. As you noted, the lamp covers do appear, but the extraneous lines between the covers do not go away. I have tried various extrusion widths, without finding any difference. The printer can handle this size because the same model in the same size, using the same slicer settings and the same printer, works when created for me by a friend using InventorPro. Almost all of the models that I am interested in have parts that are fractions of a millimeter in size.

That’s just to allow SU to create the faces, to avoid gaps to form a solid. The part is solid in SU, so it’s past that stage anyway, as you say.
I scaled the part in Slic3r, just to see if I could make the lamps appear. Although I can’t really give you an answer as to why it happens.

You can try and example the model with my Solid Inspector extension - it makes some more in-depth analysis than what Entity Info does.²

Thanks Thomas,
Inspector2 says “No errors. Everything is Shiny.” But the lamp covers do not print.
The best clue so far seems to be IanT’s observation that the covers do print if the object is enlarged. But still not a good print, because there are extraneous lines.

Did you try the files @Box provided above?


As I noted above, I did try the files from Box. I was unable to load the skp file because I have the 2017 Make version but I did try to slice and print the stl file. It failed to priint exactly as my stl file failed.

Sorry about the 2018, normally I check and save to an earlier version. I must have forgotten. I can upload again when at my computer but I think it’s more likely that you have problems with your slicing/printing software.

Well, here’s one cleaned up from this morning saved back to v8.
Upon save Sketchup fixed a ton of ID errors. I don’t know if that was causing print trouble or not.
SignalHeadTest2 shep.skp (54.7 KB)


I was able to load this version and save an stl file. I loaded the stl file into simplify3D and it looks good (the same as my model looks), but when I sent it to the preview mode (where a gcode file can be written) the lamp covers are missing (the same as for the model I created).

Have you tried updating or reinstalling you printer software.
I can print this file, so it seems to me there is some disconnect on your end.

Thanks for this suggestion. To find out if my printer was the problem, I took both your stl file and mine to the local library where they have a Makerbot printer for public use and I printed both files. They both print the light covers, although with some thin extraneous lines that I can trim away. The prints are not as fine and smooth as I usually get on my printer, but I have mine set to 0.25 extrusion width and “High Print Quality” and they are used to printing larger objects with coarser settings. Based on this and the observation by IanT that the model prints when made slightly larger, I believe that adjusting my printer (or just accepting a larger object) should solve my problem.

I really appreciate the time that you all have given me on this, and I have learned several new things from you, including how to use section planes, more about what makes a model solid, and gained some confidence in SketchUp.

I will be on a trip for a few days, but when I get back I will adjust the printer (and model if necessary) and continue my design.

Thanks again,

I have done some experiments to determine if the size of the object is the source of my problem and I have evidence that the location where I start to draw it is the most significant. For this test, I drew a simple model as follows; A 10x1 (mm) rectangle with a 1x1 rectangle adjacent to the right side. I extruded the 1x1 up 3 and the 10x1 up 2. Then I removed the 3 lines between planes, one in the front, one in t back and one underneath. I did this ten times starting at different locations in the xy plane. Four came out solid and six not. For example, if the first point of the first rectangle is at 24,50, the figure is not solid, but if it is at 32,55 it is solid. I have also done this changing the size of the model but size does not seem to be important. This feels very much to me like a round-off condition resulting from floating point arithmetic. Is there something more I need to do to get the objects to be solid. Solid Inspector2 reports “Nested instances” on the ones that are not solid but I cannot find any.

StartingPointTest.skp (1.2 MB)