Starting in Desktop


#1

How do I get SU to open in the desktop? When I open an .SKP file I get the ‘license’ page and have to click Start using SketchUp to open my design.

Thanks
Walt

Using version 17.2.2555 64-bit


#2

As long as the program is open, you won’t need to see the welcome page when you open a new file.


#3

Well, sure. But I’m not in the program 24/7. I don’t want to see the welcome page at all and I can’t find any settings.


#4

It is just a reminder that you can use SketchUp for your personal projects and accept the EULA. If you do not want that or if you are using SketchUp Make commercially, buy the license. Then you have the setting to turn it off.


#5

SketchUp Pro has a checkbox in the splash screen for not displaying it on startup. This is one of my favorite Pro features! I value it higher than DCs and Solid Tools combined!


#6

I think of it as a Welcome screen, welcoming you to use the software. Splashing sounds like you are already encountered a bug or fault…
You don’t buy Pro for features or functionality in the first place, I think… but simply to use SketchUp as a Profesional and being compliant with the EULA.
Think about how you will look through the eyes of your client: If you are not considering yourself to be a Pro, why would he/she listen/pay for this design/idea/plan etc.


#7

MikeWayzovski
It is just a reminder that you can use SketchUp for your personal projects and accept the EULA.

Somehow when I open a project to work on it, I don’t need a reminder that I can work on a project. That’s like my car telling me “Hi, I’m a Ford. You can use me to drive somewhere.”

And it’s not mentioning the EULA at all. It just says “Start using SketchUp”, like it wasn’t sure I really wanted to use it when I opened the program. My previous versions didn’t have this feature.


#8

Were your previous versions Pro and now you are using Make?
Please fill in your profile so we don’t have to guess.
The splash screen has been around since at least version SU7. (probably earlier but I wasn’t around then)
I remember asking how to disable it myself way back then.


#10

Never used Pro, and Make was all I could download based on my needs. I’ll have to turn on the other computer to see which version I was using. I do remember I couldn’t upgrade because of the age of the thing.

Yes, it is an inconvenience that I can live with IF I have to, but by asking I might not have to. I took that chance.


#11

Version 6 didn’t have this screen on startup. I can’t remember when it was added though. I kept using version 6 for about 2 more major releases since it had a better component browser IMO (no 3D Warehouse integration). It’s definitely there in SU 2014 which is the oldest version I somewhat try to make my extension support, and probably in 2013 too.


#12

In my Windows 10:
Start with Sketchup not open. Double-click the .skp file in file manager. The license page opens. There will also be an icon in the bottom task bar for the now-open Sketchup. Right-click the Sketchup icon, and click “X Close Window”. After a few moments, sketchup will re-open the .skp file you selected.