Sometimes there's a "solid tools" and sometimes there isn't


#1

I want to take a small bite out of an existing STL model that I imported. I figured I can use “Solid Tools -> Subtract” to do this.

So, I made myself a rectangle, extruded it, moved it over to the model I want to modify, selected both models, only… there’s no “solid tools” in the context menu. It’s not greyed out. It’s just not there at all.


#2

Solid tools is a pro-only feature. Your profile indicates you are using SketchUp 2017 Make. It would have started with a 30-day trial of Pro which would have given you access to the Solid Tools. When the trial expired, access to the Solid tools went away.


#3

The trial hasn’t expired yet.

I can select two of the objects I created and “solid tools” will appear for them. It’s only when I select one of my objects and the object imported from the STL, that solid tools will not appear.


#4

Then the .stl isn’t a solid.


#5

Are the components or groups actually solids?


#6

It looks solid enough, certainly looks so when printed.

How can I tell if it is solid? Is it the case there’s some open face somewhere in it?


#7

Have the Entity Info window open as you model. When you have a group or component selected, it will report as”solid” there if it is.
That’s much easier than stabbing around with the context menus.
If it isn’t solid or “watertight” for another way to put it you have some investigating to do.


#8

Upload the SKP file so we can see what you’ve got.


#9

Here’s the model. There are two rectangular solids positioned where I intended to subtract them.

picase-modified.skp (2.3 MB)


#10

The "rectangles are solid but the main model isn’t.

Holes need fixing manually.


#11

I’m just going to take a dremel to the ■■■■ thing.


#12

I suppose you’re already grinding away but I expect you wouldn’t have had any problems with it being solid if you had imported the STL using meters for the units.


#13

I decided to try meshmixer and tinkercad before getting out the dremel. Meshmixer tore up the model when I tried to do a difference. Tinkercad appears to have worked flawlessly and fairly effortlessly.


#14

It was a few seconds cleanup after scaling the model up in SketchUp. Might not have needed any cleanup ioif you’d imported at meters as I said before.


#15

Could you explain the steps you went through? Is the scale up followed by a scale down? This is just to cause some rounding to occur?

Scott


#16

SketchUp doesn’t like to make tiny faces when endpoints are too close together. You get around that by working at a larger size. You could scale up and then back down but there’s not much point in doing so for a model you’re going to export to STL anyway. STL files are dimensionless. The size of the 3D print is determined by the units you set up when you import the STL into the slicer. If you were modeling from scratch in SketchUp, just work in meters in the first place.


#17

It seems odd to me to work in dimensions that are 1000x larger than the object I’m making, but if this is the fix, I’ll go about doing it in the future. I had other issues last week where solid tools wasn’t working for me on some of my own models; perhaps it was a similar problem.’

So once this trial expires, is there any similar workflow to “solid tools” in the free version? Being able to intersect and/or subtract objects seems like a necessary feature.

Scott


#18

But since the STL file doesn’t have any dimensions, it doesn’t matter.

You can buy the pro version of SketchUp or you might purchase BoolTools2. You can do the same sorts of processes with Intersect Faces and the eraser tool. The Solid Tools are not a necessity.


#19

People often get caught in a loop where they can’t use solid tools because the can’t make a solid to begin with, when a simple intersect or even an edge and push/pull would do it. Solid tools only automate something that is already possible, learning how to do things manually is far better than learning with advanced tools and extensions.


#20

I think where the units will make a difference to me is that I typically do a lot of work in inches, and sometimes it’s convenient to use both inches and millimeters, lest I have to keep open a converter to constantly convert between the two.

Thanks for the pointer to BoolTools2. This seems like a viable option. The other “pro” feature I’m using extensively is the DXF import, which I understand there’s a plugin alternative to that as well. The license fee for Sketchup Pro is more than I can justify spending, so I’ll have to ween myself off the pro features that I’m currently using during the trial period.