Solidworks import surface won't take texture

I have imported a model from solidworks into SketchUp I can’t apply materials to the surfaces. I click on the surfaces with the paint bucket tool but nothing sticks. Can anyone help?

Could you upload the model (or if it is too large, put it on a share site and post the link here)? Without that, we would only be guessing.

It helps you to know exactly what you’re actually applying the paint to.

Activate the Select tool and Right Context Click on the imported geometry > Entity Info

What does the Entity Info box tell you about the entity you’re trying to paint?
Here, a screenshot of the Entity Info box would help us help you.

Most times that I’ve had that happen (which is very infrequently) it’s because the surface is double-skinned. It’s usually been after some tricky bit of editing in which you complete a loop and SU keeps creating faces where you don’t want them. It might be that Solidworks imports create double surfaces by default. I know there is a program for creating boat hulls which did it every time…so it’s not unknown.
Try deleting a face and see if there’s another one underneath.

Another possibility is that you have imported the file using a wrong import unit (like Meters instead of Milimeters) so the scale of your model has become enormous and the textures you apply will look like uniform colour.


I figured I’d start simple and find entity info. Here is what I have. It looks like the shingle material has been applied but it does not appear on screen. I will dig into the other suggestions next. see attached screen shot of entity info.
Thank you for your input.

How about sharing the SKP file?

I got some of the surfaces to take the material but only after exploding them several times. Now when i apply them to adjacent surfaces it changes everything.? I had to create a simple test model to import and upload because the original is 46MB. This model does the same thing.SU test 2.skp (179.9 KB)

Simlab Solidworks Importer
Here are the settings I’m using.

The stone doesn’t show because you are applying it to the container. The faces inside the container(s) already have a material applied. Materials on faces override materials on containers.

You can tell the faces are painted if you look at Entity Info and drill down to the face.

The wrapper is painted as shown when you select the top level component.

Removing the material from the faces and leaving it on the container makes it appear.

The better thing would be to paint the faces instead of the container. Especially if youwant to have any sort of control over material orientation.

And you probably don’t need the nested components as your model has.

1 Like

Thanks for the help. I didn’t even realize it was like that. I’m a SolidWorks user and definitely not a SU expert by any means so i appreciate your help.