Solar North plugin not working in Version 22.0.353

I’m on Version 22.0.353 and for some reason Solar North is acting all strange.

If I toggle Solar North or try to set Solar North, the moment I move the pointer I get this alert/error:
Screen Shot 2022-10-30 at 10.47.02 pm

Any suggestions?

I’m not seeing any problem with the plugin in SU2022 on my end. Do you get the black compass incon? Is it always the same 270°?

This is what I’m seeing with it:

Which Mac OS version are you using?

It works here too. Windows 10. Tested both with a geolocated model and a blank new file.

Are you using a new M1 Mac?

A scene saves the north angle so if you already have scenes in the model the angle will revert to the one in the scene when you switch to it.
Go to each scene, change the angle and update the scene(s)

I don’t know how to use scenes, so I don’t believe that’s the issue.

No this is a Macbook Pro, a few years old. I’m using OSX Big Sur 11.7.1, 2.3GHz quad core i7.

Yes I get the compass icon, but the moment I click the centrepoint to ‘set’ the origin, this dialog box comes up, and whenver I move the mouse after that, the dialog box comes up again, and again and again and again. I have to keep hitting Esc over and over again to prevent the dialog boxes appearing, just to move the mouse up to disable the plug in from the Extensions menu…

It’s not always 270 deg. It depends where I move the pointer. Each time the mouse moves, the angle specified in the dialog box is different.

When I remove the Extension and reinstall it from the Extension Warehouse the warehouse says:
“This extension is marked as being not compatible with your Operating System or SketchUp version. Proceed anyway?”

So there’s clearly a known issue with this version of SU2022 or Big Sur?

It may be something related to the operating system. Solar North does work with SketchUp 2022.

It would be a good idea to add the OS version to your profile. That information helps us help you.

OK I think I’ve worked out where this is happening. I have a plugin installed called designPH used to model Passivhaus building elements. Before this plugin is activated, SolarNorth works fine. As soon as I activate the designPH plugin and tools, this issue starts happening.

Ah. Well it sounds like you have solved it. The two extensions don’t play nicely with each other.

Their website says that v1.5 is not compatible with SketchUp 2020 and later. If you’re still running this older version, update to their v2 plugin.

Otherwise notify them that their plugin is interfering with another.

Perhaps hit the spacebar to deactivate the tool and activate the Select Tool (rather than moving the mouse) ?

Yep - just seen that there is an upgrade of DesignPH which fixed the issue. Sorry to waste your time!!

1 Like

No problem. We like it when things are fixed! And it helps others who encounter the same issue.