Solar North and scenes

I have a model ready with all its plans, sections and elevations saved as scenes. After weeks of work I realized my model was not geo-located. No big deal, as far most of the work goes.

However, as I want my elevations to have shadows, I decided to place North in the correct position using the Solar North extension. It works fine as long as I do not change scenes: then the sun’s direction goes back to its normal position in Sketchup, that is, aligned with the green axis.

What I want is to be able to change the sun’s position and for each scene to keep the new position. Right now I am not being able to do it even though I updated Shadow Settings in the Scenes dialog.

Would any of you know how to make the new sun’s position stick?

Thanks.

hello, you have to update each scene after setting the north position with the tool.

depending on how many different settings you have for each scene, it might be faster to create them over again starting from one for which the north is correctly set

or, in the scenes panel, when you pick update button, you can chose what is needed to be updated for a scene, just untick everything but shadow settings

One important thing to remember if you want different solar north settings for different scenes is to untick Scene Transitions in the Animation settings.

Aaargh - that is it! I wonder if it is documented anywhere. I have always claimed that solar north is independent of scenes.

That’s a good question. I don’t know. It’s one of those esoteric details that isn’t widely known. Maybe it’s partly because not a lot of users use the Solar North plugin. I remember learning it years ago when the plugin was first released. Then forgot about it. I leave scene transitions turned off while I’m working because I hate waiting for the camera to orbit around to the new location. That means that different Solar Norths between scenes works for me without having to really think about it.

I have a vague memory of a native tool for setting the north in early versions of sketchup, am I wrong ?

Not really. Solar North was originally included with SketchUp Pro. It was later removed and served up as a plugin. Many users have no use for it so I suppose they figured it could be optional. Of course it’s a pro-only plugin so it doesn’t work in Make.

1 Like

Thanks for all the contributions!

In fact, I knew I have to update after setting up the new sun position. The reason for it not sticking was this: in order to set the new sun position I had to leave the section view and adopt a 3D view. Then I would set the new sun position but when going back to the section view it would revert to the old sun position. I solved this problem by getting the sun’s angle while in 3d and then applying it to the sections using the tool at the bottom of the Solar North toolbar, the one that allows one to enter an angle.

I probably could have done it by disabling the Shadows settings in the scene, changing the sun and, when reverting to the section view, enable it again and update the scene.

as I mentioned earlier, you don’t have to get back to a scene to update it. you can enter the new north angle with the set north tool in 3D view and update any scene through the scene panel ( and not the scene tabs) unticking everything but shadow settings.
But I’m glad you sorted it out !

@Paul: Or just toggling the Shadow Settings on and off.