Sketchup Won't Close

Hello, I previously used sketch up to make some models which I saved to my desktop. I am on macOS Catalina. I accidentally opened one yesterday, and when I tried to close, there was not any buttons to exit the app or minimize it. I opened another model, and the same happened. I tried to quit by clicking on the app with two fingers, but when I pressed quit, nothing happened. I clicked hide so it wouldn’t clutter up my desktop for the time being, but how can I quit this app. I am on a 2017 MacBook Air, and am using Sketchup Make 2017. Thank you.

You can force-quit any app and this isn’t specific to SketchUp.
Press command-option-escape (⌘ ⌥ esc) then choose the program that you want to force-quit then click “Force Quit”. Any apps that have been unresponsive will be red in the list.

You could also right-click(two fingers on your trackpad) on its icon in the dock, then hold down the option key (⌥ ) and the “Quit” at the bottom of the menu changes to “Force Quit”.

I tried both of those, they didn’t work

Having no buttons to quit or minimize might occur if you made SketchUp full screen by pressing the green dot at the top or by some macOS shortcut. When you do that, these buttons are hidden. You have to float the mouse up at the top of the screen to reveal them.

Do you have multiple “spaces” (virtual desktops) set up? I have sometimes seen that when SketchUp has no open model and I move between spaces, SketchUp removes its menus and toolbars (sometimes called “chrome”) from the original space. When I come back to that space, it won’t quit until I click the icon in the dock to reveal the chrome. The Trimble team haven’t been able to reproduce this, but it happens regularly to me.

However, the techniques @McGordon suggested should work in every case. Force quit is a basic macOS operation that SketchUp can’t ignore or refuse regardless of what state it is in. Although it can sometimes take a while to complete, I have never had force-quit fail. I’m at a loss what is happening in that case.

Try this command in Terminal, if you’re comfortable using Terminal that is. It’s in /Applications/Utitlities or search for it with spotlight. Copy & Paste this line into a Terminal window, then press return.

kill -9  `ps -u \`whoami\` | grep SketchUp | grep -v grep | awk '{print $2}'`

Seeing if you are in full screen or not can be tested by typing control-left arrow or control-right arrow. That will change the screen to show the next or previous full screen application. When you are in SketchUp, mouse over to where the Apple logo would be, in the top left of the screen. By the time you get close the colored circles should have appeared. Click on the green one to come out of full screen mode.

If you right-click (or control-click, or two finger press on a trackpad) on the SketchUp in the Dock, if it says Force Quit instead of Quit, then it’s already locked up.