SketchUp Web just showing loading screen

I’ve been using SketchUp web happily on my chromebook for a while. It worked a week ago, but today it just gets stuck at the loading screen.
I’ve tried a different account on the same chromebook, tried deleting all of my cache and browsing data, and switching to the beta channel which were all suggested fixes from other topics but nothing has worked for me… any ideas?

We haven’t been seeing this issue ourselves, but are eager to investigate. Will you open the Chrome Javascript Console (View > Developers > Javascript console) and then reload the app? If you can take a screenshot (or better yet copy/paste) the contents of the console, we’ll take a look. If you prefer, you can send me a private message with the screenshot or text file.

Continuing the discussion from SketchUp Web just showing loading screen:

Hi Mark
Thanks for getting back to me. I tried to copy paste the javascript contents but it was full of hyperlinks and im only allowed to post messages with two hyperlinks so i’ve attached a screenshot.

Thanks for your help


Mark, there are two other threads about this already. I asked Brad to look at the errors I posted. Basically, something broke 32 bit Chrome in the last day or so. Using a 64 bit browser makes it work, but I expect that may not be an option for some people.

Does that mean there’s a fix on the way soon?

I don’t know, but the right people are looking at the issue.

im having issues iv cleared all my cache and cookies im on an oldish chrome book maybe 6 years old does not get updates anymore i think its a 64bit but unable to get past the loading screen for a good week

I’m having the same issue on a Chromebook. Any idea if a fix is in the works?

Yes, someone posted yesterday, in one of the other topics, that the problem has been found, and a fix is being worked on.

Great to hear! Love the product so looking forward to being able to use it again.

This topic was automatically closed after 91 days. New replies are no longer allowed.