SketchUp Viewer within Trimble Connect - Tags (layers) usage?

I’ve got a project that I’m mostly doing myself, but I’m making viewable to a friend by storing all my project files (and syncing them with Trimble Connect Synch) in a Trimble Connect Project which I’ve shared with my friend.

I just tried using the viewer within TC myself, and to my consternation it seems that I can’t turn tags on/off!! Am I missing something?

Now I know I can encourage my friend to get one of the SketchUp Viewer apps, then he could download my models and look at them there, but although he’s quite technically literate, he’s a bit of a curmudgeon who won’t appreciate the extra steps involved!

And I’m too much of a curmudgeon to set up scenes with tags just to let give him a way to view things with different sets of layer (dagnabbit, I meant tag! Still getting used to the name change!) visibility - come to think of it, does the TC viewer allow scene changes?

Any ideas?

When I tried this I ran into a problem with the web app reading the shared model, maybe it will work for you.

In the TC viewer you can click on the three dots, and choose to View in SketchUp. That should open the model in the regular web app, and then you can use tags.

If you also see an error it may be something that needs reporting.

1 Like

There are no scenes in TC, there are Views. You would have to create them, for there is no ‘scene-to-view’ conversion.

While a SketchUp Model can act as an ‘Projecthost’ on itself (your .skp file), Trimble Connect just considers it as one of the multiple platforms that contribute a ‘datamodel’ to the TC-project.

It will convert the .skp to a fileformat of its own, for faster viewing in a browser (desktop, tablet or phone)
That fileformat is capable of viewing far more complex or larger models, and view multiple of them at the same time.

Not all Attributes from a SketchUp model are converted, merely just the model tree and its Objects data (Advanced Attributes of component, Classifications and DC-attributes)

‘Open in SketchUp’ will launch the original SketchUp file, not the converted TC-file.

Check out this discussion How to control SketchUp layers or scenes inside Trimble Connect?

I like this solution!

Mostly because it let’s my curmudgeonly friend not have to be coached through installing anything, just coached once or twice on finding the “three dots” - his Chrome (and yes, I do know he uses Chrome) will open up a new SketchUp Free tab/window - he won’t be asked for a login since he already IS logged in to access Trimble Connect.

He can even make changes. That’s both good and bad. Good because I want his feedback. Bad because he doesn’t (yet) know what he’s doing in SketchUp Free. Bad also because I’m using @Medeek’s tools for the basic elements including foundation, floor (using truss), wall, and roof (again using truss) and I’m worried about him possibly “breaking” the internal structures that @Medeek uses in his tools!

But as long as he doesn’t save - until he knows what he’s doing - it should be OK!

1 Like

That’s useful to know, but one of the request requirements was to not need to download a desktop viewer. If downloading a viewer was allowed it could then be the SketchUp viewer.

Hi @colin,

I tried @MAtt’s solution, and it doesn’t involve a downloaded viewer. It opens web based SketchUp and loads the model. Only hard part is finding the “three dots”! It turns out you have to open the model in the TC viewer THEN use the “three dots” within the viewer.

He wrote something about how in the web version you don’t get access to the model hierarchy, but in the desktop version you do. I don’t mind if I misunderstood that part!

1 Like

Here is the thing: Not all Objects are equal.
Plugins luke @medeek generate zillions of Groups, in order not to bloat the component browser and performance issues with components.
However, to have a valid GUID in Trimble connect, all objects should be components. These GUIDs are leading in breaking down the model in portions of data, viewing them only (select), organise them (create job-specific TC groups and adding data on the fly with the workflow extensions (business premium only, the owner of a project can add job-specific properties inside a project)

The ‘Group by’ in TC doesn’t work with the hacked method of ‘nested Layers’ by grouping in SketchUp (it doesn’t generate a valid and therefore recognizable ID)

So, you need to have a ‘flat’ organized model (Tags only or nested Geometry with components, not a bit of both)

And your point is? You may be completely correct in what you say, but none of that makes a bit of difference to use case!

I’m not trying to interface with other professionals who may well be using different software. I’m just trying to get my curmudgeonly friend to be able to view my detailed models without being restricted to the exact layer set that was visible in my last saved version of a few SketchUp models that I want him to look at.

He was at my home for brunch this morning. And in about 5 minutes was able to show him:

  • How much control I have over what is visible (using tags) in a model I’m working on locally.
  • How little control he will have over viewing them when he access them directly through TC and
  • How he can have the same visibility control as I do WITHOUT downloading ANY additional software by using @colin’s solution of opening the model in web based SketchUp through “three dots”

Remember, I said my friend was technologically literate, but a bit of a curmudgeon. And he indeed embraced (despite his curmudgeon tendencies) the idea of being able to get to a different, more capable viewer through a couple of mouse clicks.

1 Like

My point is that Trimble Connect is not ready for one-on-one conversion of a regular SketchUp Model. Open in SketchUp (which opens up in Free or Shop, depending on type of Plan) will.
Unless this is addressed, SketchUp users can or will not take full advantage from TC.