SketchUp V-Ray RT GPU CUDA issue


I have spent considerable time to find a solution for this issue by googleing it but had no luck. So as last resort I raise this question to smart, experienced chaps, you.
I have an architectural model made in SketchUp. Normally after modelling I do the materials and renderings in 3DS Max but we have arrived to a point where we need to do these in Sketchup. So I fired up the RT engine, with the CPU it all works well, looks as it should be. The CPU is not too fast so I wish to use the GPU. The issue is when I switch to GPU CUDA, all the colours go wrong. Do you know how could I fix this? Please see the images below.

SketchUp: 2016 64bit
Vray: 2.0 for SketchUp
Platform: Win 10
GPU: Nvidia GeForce 930M

Your help would be highly appreciated.

I am not aware of this issue, but it would be good to make sure that you have the most current version of Vray as they often patch things without letting us know what they had done.

The current version listed is 2.00.26579.

Also, you need to make sure that your graphics card and its driver supports CUDA. (updating to the latest graphics driver?)
I just checked, Nvidia GeForce 930M does support CUDA.

Are you sure rest of your values for the render is identical? It almost seems like it is somehow flipping through different Color mapping type. (Reinhard, Linear Multiply, Exponential, and etc.) Anything that effects the white balancing.

Perhaps also try GPU OpenCL to compare?

I was just reading up the page in Chaosgroup,
I am not sure if this is true, but it reads as “V-Ray RT in SketchUp does not currently support rendering on the GPU”

I have also thought that it is just darker and the colour temperature is warmer. But it is not. In fact some things are renderd black. OpenCL does not work in my case seems like it is not supported by the driver.

And the CPU vs. CUDA is the only variable in this case?

btw, will you able to share the file so I can give it a go with different settings?