Sketchup/Twilight - rendering results in photographic negative

Hi Brain’s Trust … hoping you can help (and please use small words and very clear step-by-step instructions as I am still new to Sketchup.

During the rendering of my shop model the light and shadow appears to have inverted (like a negative of a photograph). I have made a shop model before without this issue.

All light are switched on (checked all 30-odd individually) with the attenuation being an “inverse square” (standard setting). I have tried adjusting the light size/energyattenuation with no affect.

When I process the model to the Twilight render program the initial view shows the internal lights are how I want them … but once the Twilight program runs it renders black/shadow where light should be (screenshot) - and light where there should be shadow. Just like a photograph negative. Obviously I’ve “inverted” my “rendering light” somewhere but no idea where/what/when

I have tried different clarity options - have googled my freckle off - peered into every tool option I think might make a difference - and still no change. Help! I am sure the answer is something very simple.

I am using the Student Pro 2018 program

Screenshot%20(71)

Here’s a screenshot of how the image looks when it initially uploads into Twilight - and how I want it to looks when rendered

Screenshot%20(70)

Is face orientation correct in the model? Show us a some screen shots of the SU model with face style set to Monochrome.

Or better, upload the SKP file to drop box and share the link so we can examine it.

Hi Dave

Below is the screen shot of the SU model … I’m very new, so I’ll google on “face style” and see if I can work out if something there is what happened. If not success then I’ll upload it to the dropbox.

I did check that all my internal walls/floor/ceiling were correctly facing

View>Face Style>Monochrome

Providing the model would give us a whole lot more info and make it much faster to help you.

1 Like

No banana - view>facestyle>monochrome just changed my model to look like the below - but the rendering still came out the same inverted light - I’ll change it back to it’s default of “shaded with textures” - and work out how to upload the file onto here

Well, your screen shot shows reversed faces–the blue ones. If there’s a few, there’s very likely more and they could be the problem.

1 Like

I just went thru the whole model and the front face of the facade was the only reversed section - although not sure which way to have the windows as if they’re the right way on the outside, then there showing their back inside.

There are a couple of object, uploaded from the 3D warehouse, that are showing a blue-ish face - tried exploding and reversing but that just messed the models up and suspect the blue-ish may just be shadowing.

The “reverse” light rendering result is the same from a close up inside the model as it is outside - so is something affecting the whole model rather than just the above screenshot-ted.

Uploading model to dropbox now … will share after the school run (no bus out in the country)

Here is the link - if you click on “open with Sketchup” it will open.

I’ve fixed up the overlap on the rear right hand corner (next to internal door) - and have extended the internal door/architrave, to become a solid, through the wall

Your dropbox file is somehow incorrect, you need to log in to access it.
It shouldn’t require that.

did this work?

(https://www.dropbox.com/s/4qpa38qa9srxjsc/module%2014%20sketchuphomewares.skp?dl=0)

I am not very technical …

First, you should use groups for every construction element, like wall, floor, window, door, etc.
Then, use the template Twilight material for glass, like in this GIF. You have two glass materials for the windows and doors in your model.

I’ve got a lot to learn - thanks heaps.

I decided last night to simply pull the entire model apart and put it back together again, piece by piece

1 Like

Took a look at your model. Simply put there is a lot of not so good things going on. Agree with mihia’s comments about better use of groups and components. Some more things to point out… Your model had a large amount of confusing layers. Most of the layers were associated with one object ( a trunk ). It’s best to delete these unneeded layers moving everything onto Layer 0. Also saw quite a few reversed faces. Many of them were on the small decor items. I assume you got a lot of these off the 3D Warehouse. It’s always a good idea to first download warehouse models into a separate “parts” file and check them for problems and clean them up before using. On last thing the large image on the left wall and the picture image on the right wall were both imported as images and placed directly against an existing face in the model. They should be imported as textures and “painted” on the face where you want them. The way you had them will create “Z Fighting” between the two faces and cause rendering problems.
Now for issues relating to using Twilight. Your biggest issue is you had two Twilight point lights with a diameter of 1000 mm. The size off your Twilight lights should reflect real world dimensions , a standard lightbulb is about three inches in diameter. Most of your other Point lights were larger than they really needed to be although not as bad as the first two mentioned. A lot of your Twilight lights also intersected other geometry in the model. I think a combination of oversized and over powered lights , intersecting other geometry and the handful of reversed faces all played a role in the odd results you were getting.

1 Like

All taken on board.

What was interesting - I totally dismantled the model by moving out all the added 3d warehouse items (rendering all the time to see if anything that I may have “exploded” was the issue). Nothing. Deleted the building. Drew a red/green axis rectangle and rendered - turned black. Drew a red/blue axis rectangle and rendered - all good. Seems the issue is a setting somewhere affecting the green axis. Both rectangles had front face presenting. Still no idea. Will simply open a new document and start again with better knowledge.

Hope you don’t think your model was total trash , it wasn’t. I did some clean up to it and deleted your Twilight lights. Set the lights back up in a more sensible way and ran a test render. Test was 25 passes Easy 9. Took about an hour on my iMac. Posting the render and a screen shot of how I set up the lights. Hope it makes sense. Ask questions if needed.
There was no need to create so many lights in Twilight. If you have a bunch that are going to be the same , create one than just copy how ever many you need.
Final note. I couldn’t recreate what you had happen in your last post… Have no clue what was going on.

Forgot to mark the screenshot… Can light Radius is 1 inch, Canopy light radius is 1 inch

Wow - it looks amazing so thanks. The issue must’ve been something on my computer with the green axis - so starting from scratch - armed with lots of new information and knowledge. Think I might pinch your idea for the pavement too

Don’t really learn anything until you mess up :smiley:

1 Like

Hope it helps. Forgot to mention I simplified the ceiling can light, deleted excess stuff and cut holes in the ceiling for them. That allowed me to place the Twilight point light up in the can were it belongs. Just want to reiterate the biggest cause of the problems you originally had was the Twilight light set up that got a little out of control. Don’t beat yourself up it’s all part of learning.

1 Like