Sketchup to Cura - allegedly not watertight

I did in fact create a bug report about it! Before SketchUp 2019 you had to choose a template, but with 2019 and later it is possible to start a new document without it being based on a template. I happened, by chance, to have done that last night, ran into some problems, was in a panic for a while because I thought it was a general problem. Then I found that documents started from a template didn’t have the problems, and also I noticed that your file was using the blank document as well.

So, it’s a problem that may have been around for a while, but hasn’t shown for many people because it is out of the ordinary to start a new document that is not based on any template.

@DaveR
Same result with your stl.

@RLGL
I think you were right. All I did was scale down in Cura a few percents and the slice button worked instantly. Strangely though I was correct in that there is a centimeter margin around the widest points AND adhesions are off.

Edit:
The adhesion setting was off on the ‘recommended’ view of settings but it did have the skirt enabled on the ‘custom’ settings. I figured that out and was all excited but then I went back and read @endlessfix 's answer and noticed that you said exactly that already.

Thank you!

1 Like


So it finally printed at 20% fill pla. Feels great! Now I’m wondering what this crazy layer is about 1cm from the top! Is that what it looks like when it’s not ‘watertight’? And I think that spot on the bottom where there is about a 1/4" of gap is the point when I turned off the 50°C bed thinking “this is well adhered to the bed by now”. It has those gaps in all six corners.

@colin
I made the lid pieces and they received the same error message. Then before I printed them I started a new .skp, deleted the 2d woman and pasted the models into it. I exported them piece by piece into cura. Same error message. Then I found that after I slice them and go to the preview tab, cura shows me what the fuss is about. It is that ‘crazy layer’ I showed in my first printing photo. It appears in a seemingly random spot on the models. In all 3 things ive made so far it’s been a single layer that shows up ONLY in cura’s preview after slicing and it prints it, although the single layers have been easy to remove with a utility knife.

Next I’ll need to rebuild them from scratch I suppose using the non-blank template.

A little tip: you are using a free version of SketchUp, You need a version that supports plugins. These two, Solid Inspector 2 and TomTom’s Solid Inspector. Between them they will reveal many flaws that are not noticeable.

@RLGL
Ok. I did upgrade to shop (web) and its solid inspector says nothing about those mysterious layers. Did anyone here run my .skp through those plugins you mention?

Those solid tools were a lifesaver making the lid parts!

Concrete is setting while we speak :slight_smile:

Both report as free from error.