Sketchup thinks a component is not a solid

I’m just now starting to learn sketchup, trying to construct a timber frame kiosk and i drew a post and made it a component, then manipulated it. I connected it to a beam, and used the trim tool to cut the mortise in the post. Then went back to it to cut another mortise and sketchup now tells me it is not a solid…when i can see perfectly well the other housings and mortises i already cut in it. The same component on which I already used the solid tools is now reporting as not a solid. And it is also a group, somehow. Could that be the problem?
Any other ideas?

Share the .skp file so we can see what you’ve got. There’s surely a logical explanation that will be easily solved with the model to look at.

Sure.
kioskrev2.skp (351.2 KB)
here it is

Is it this component? It shows as solid but for some reason you have the component inside a group called Difference. No reason to have the geometry double wrapped as it is.

By the way, I’m seeing things that don’t seem to fit very well. Is that important to you?

One thing I would recommend is turning off Length Snapping. That just tends to get in the way of accurate modeling. I would also increase Precision to something higher than you would use in reality.

1 Like

Hi Dave,

  1. I’m sure i didnt create that group, and name it difference. I see it there, but I don’t want it. Is “explode” the right command to dissolve the group? I’ve searched for the “ungroup” command but can’t find it. And I think I tried exploding. I know I tried deleting and starting over. I suspect the thing to do is start over and be very deliberate. This model took me hours, but it is more or less my first attempt, and I’ll have picked up speed.
  2. Yes, that kind of inaccuracy does matter. What is length snapping? I’ll turn it off for my second attempt.
    Thanks,
    tom

Normally a group called ‘Difference’ is created when one of the native solid tools modifies a group or component. My guess is that you trimmed the post with the knees and then opened the group for editing and made the component called ‘post’. The correct thing would have been to right click on the resulting group and choose Create Component to convert it back to a component.

Yes. Explode removes the object wrapper and throws it away. Explode the group and not the component inside.

Saving the post component isn’t terribly difficult. I might suggest starting over more to make sure you have everything modeled correctly and in the right location. There’s evidence that you are modeling parts elsewhere and moving and rotating them into place. This makes for a lot more work than you need to do and it can result in errors.

Length Snapping is a setting that affects everything from the Line tool to the Move tool. It makes the tool try to snap to the nearest interval established in Window>Model Ino>Units. It’s generally recommended that you turn that off (I’ve never ever seen a recommendation to turn it on to be honest) and as I wrote, I would set Precision finer than you want. I would use 1/64th in for Architectural or Fractional units here. I wouldn’t be intentionally modeling to 64ths but I want to see them in the model if they occur so they can be checked and fixed if needed. An easy way to do a check is to run a cutlist of the model. Here you can see there are quite a few objects that probably need attention. The shingles are another story

You can start a brand new file, edit the Units as needed, and then immediately use File>Save as Template to create your own default template. Then you can use that for future projects and not have to worry about changing those settings.

Okay, that’s a lot of good information. Thanks. I’ll be back in touch, I’m sure.

I was going to suggest that you get eneroth Solid Tools from the Extension Warehouse. They will not convert your componets to groups when they modify them. This makes for an easier workflow.

The problem with the length snap setting is that it means exactly what it says and that isn’t what most users expect. That is, it does not snap new points to a grid, rather it snaps the length of actions to be a multiple of the set snap length. So, for example, if a point happens to land on x = 3.01 for whatever reason and you then try to draw a line of length 4 from that point it will be snapped to x = 7.01. Many users expect it would snap to 7.0. The length snapping causes small position errors to propagate, it does not fix them to “nice” locations.

DaveR
I used the trim tool and it created the new component ‘difference’ from the original I called rail (making a door for cabinet).

The Trim tool in the native Solid Tools set converted your component called Rail into a group called Difference. The Trim tool in Eneroth Solid Tools will leave the trimmed component a component AND also make the same trimming operation to all other instances of the component.

An array of components. Native Trim first, Eneroth Solid Tools Trim used second.
trim

It seems that is only available on the Pro version. I have the yearly subscription.$299 vs $699 is really the only reason why

You are using SketchUp Pro. Look at the top of the SketchUp screen when you have it open. You have the native Solid Tools so that would be another clue.