SketchUp Taking Priority of SpaceMouse over LayOut

spacenavigator
bug
layout
windows10

#1

Has anyone else had issues with SketchUp taking SpaceMouse priority when trying to work in LayOut? With SketchUp closed, I can use my SpaceMouse to zoom in and out in LayOut, but if I leave SketchUp open in the background, nothing happens when I try to zoom in LayOut. I jerk around on the SpaceMouse frantically for anywhere from 5 seconds to 5 minutes, depending how sleepy I am, then see SketchUp open, click on the window, and of course whatever model I was working on there is now ten miles away from my camera position, since the SpaceMouse has been actually orbiting in SketchUp, even though it was minimized.

Very annoying, and hasn’t always been. I can’t remember when it started for me, whether SketchUp updated, Win10 update, driver update, new computer…no idea. I’ve put up with it for months actually, but finally got fed up and posted.

EDIT: In case my question isn’t clear, I’m not only asking if anyone else has experienced, but if anyone knows a remedy. :slightly_smiling_face:


#2

I use a SpaceMouse and a trackball mouse but I only use the SM when I am in Sketchup itself. In fact, I only use it when I am working in Sketchup in 3D. If I am working in 2D, it is not very helpful as you need to stay viewing the scene axially most of the time which is much easier using a wheel.

Layout is essentially a 2D program using viewports to give a 2D rendition of a scene in SU. It sounds to me like you may be clicking into a viewport and moving around as if you were in SU. That is not recommended practice as it modifies the scene and destroys the link with the SU file. I would not find much use for the SM in LO.

Sorry, this doesn’t fix your problem but it does question how you use LO.


#3

Thanks so much for response.

Sorry, I’m not always good at explaining my problems. I am not clicking in the viewport in LayOut. I am using LayOut in its intended use, making 2D drawings from a working skp file, in my case it is architectural/interior design prints. Might be weird of me, but I use my SpaceMouse in LayOut, and in other applications too, for simple zooming and scrolling that most people do with a wheel. It’s just second nature to have my left hand on the SpaceMouse when I’m sitting at my desk. In Adobe Acrobat and LayOut, it is faster to zoom in and out (enlarge the page, not 3D) with the SpaceMouse than with the wheel on my trackball. It’s an action my muscles are used to, it’s almost as awkward for me to get around in my LayOut drawings now without the SpaceMouse as it is in SketchUp. Again, might be weird, but it’s what I’ve been doing for the last few years, and now there seems to be a bug that’s messing me all up :worried:

I often have the same project open in SketchUp while I am working on the prints in LayOut. This way if I notice an error or omission, I can quickly switch to SketchUp, fix, save, and switch right back to LayOut and update model reference. Like I said in original post, I had no issues for years, but now if I leave SketchUp running, though minimized, all input from SpaceMouse happens in the SketchUp workspace.

Since when does an input device work in a minimized window anyways? It actually seems very strange to me. A mouse never does that. When you minimize a browser, and try to scroll (with your mouse) in windows explorer, it doesn’t keep scrolling down the page you were looking at in your browser. You’ve minimized that window, that means whichever one you now have open is supposed to receive the actions of the input device, peripheral, whatever you call em.


#4

OK. How did you get your SM to work with LO? When I am in LO, the SM is disabled. I’d be intersted to see if I could reproduce your issue.

Standard practice for me too.


#5

The SpaceNavigator is unfortunately not so much comparable to a (2d/3d) mouse. It is a piece of hardware that controls a specific application.

SketchUp listens only to standardized input events from the operating system, but SketchUp does not understand SpaceMouserish (it does not even listen for it). The SpaceNavigator extension that you install in SketchUp makes SketchUp move the camera when the SpaceNavigator proprietary driver receives events directly from the device. It is probably here where something is going wrong, because the extension still receives input irrespectively of window focus.

Have you tried completely uninstalling the SpaceNavigator software, driver and SketchUp extension, then reinstalling it?


#6

I didn’t do anything special. It just works. So long as SketchUp is not open. Just did clean reinstall, and it works the same.

Yes I did, and just did again to be sure. Same deal.

This makes sense, thanks for explanation. I tried using the two menu buttons on the SpaceMouse with LayOut open (I have the SpaceMouse Compact) and my customized radial menus from SketchUp show up, so what you’re saying is clearly the case.

I just can’t understand then how it used to work for me and doesn’t now.


#7

A possibility is that the SpaceMouse could have two modes (one as standard 2d pointer with scrollwheel), and one through the SketchUp 3DConnexionextension. Maybe they are conflicting, that means the SketchUp extension does not “release” it when the window is out of focus?


#8

Sort of, not exactly. It does release for other software, not for LayOut.

This conversation is prompting me to experiment, not that I didn’t before posting, but not to the same extent. Something interesting I never noticed before:

Step 1 - I open SketchUp. SpaceMouse functions normally.
Step 2 - Minimize SketchUp, open LayOut. SpaceMouse does nothing in LayOut. Back to SketchUp, SpaceMouse has been reacting in SketchUp whenever I touch “joystick”
Step 3 - Open Google Chrome. SpaceMouse acts as scroll wheel, scrolling down webpage.
Step 4 - Back to LayOut, with SketchUp and Chrome still open. SpaceMouse functions as expected in LayOut, zooming in and out like scroll wheel, as long as Chrome is the last thing I had open, not SketchUp.

So basically, it takes opening an outside software to switch from the 3D mode to 2D mode like you were saying.

I’m starting to think it has something to do with LayOut being sort of a “child program” to SketchUp, LayOut doesn’t have identity of its own. After starting another software that prompts 3DConnexion to switch to 2D mode, SpaceMouse works in LayOut window until 3D mode gets activated again by opening SketchUp window.

Hope that makes sense.


#9

Screenshots below that (I think) confirm this.

First, 3DConnexion properties after switching from SU to LO. Notice “active software title” at top of dialog.

!

Now after switching from Chrome to LayOut.